Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008521 [DCSS] Bug Report crash have not tried 2014-05-09 06:05 2014-08-14 23:10
Reporter Gerad View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008521: Crash when Qazlal dust cloud spawned in iron grate
Description I was walking through the level as a Qazlal worshipper and found the Trog vault with the moth of wrath in iron grates. The game crashed. The crash log returned this error: "ERROR in 'cloud.cc' at line 358: cloud sparse dust in iron_grate at (52,30)".

I am playing on CAO webtiles with username Gerad.

The crash file is attached.
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-Gerad-20140509-035749.txt [^] (42,437 bytes) 2014-05-09 06:05 [Show Content]

- Relationships

-  Notes
(0027010)
neil (administrator)
2014-08-14 23:10

The problem wasn't actually those grates. Rather, the boulder_corridor_run vault popped up a grate on a square that already had a cloud. This was fixed (to destroy the cloud when that happens) in 0.15-a0-1267-g1be7c1f, thanks!

- Issue History
Date Modified Username Field Change
2014-05-09 06:05 Gerad New Issue
2014-05-09 06:05 Gerad File Added: crash-Gerad-20140509-035749.txt
2014-08-14 23:10 neil Note Added: 0027010
2014-08-14 23:10 neil Status new => resolved
2014-08-14 23:10 neil Fixed in Branch => 0.15 prerelease branch
2014-08-14 23:10 neil Resolution open => done
2014-08-14 23:10 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker