Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008510 [DCSS] Bug Report minor always 2014-05-07 15:28 2014-05-09 08:34
Reporter golthoon View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008510: Dithmenos is delightfully inconsistent and lenient
Description My lord and savior Dith swears that this Rod of Clouds is forbidden, I suspect because it is liable to create enormous amounts of light-bringing fire... but I have been using it with impunity, creating all kinds of clouds, fire included. He even appreciates it when I fry things thus. (I feel guilty for reporting this, since it is incredibly, nay UNCANNILY convenient.)

Additionally, fireflies, mounted or otherwise, despite regularly emitting light at me, do not please Dith any more than monsters not so endowed.

Pursuant to the above, shouldn't I be awarded bonus piety for killing a monster who was emitting light at time of death? A flaming yak, for example. "But you're the one who set it on fire," you might reply. Why, if that were true, and I was the source of the light, Dithmenos would have punished me for it. :smug:

To settle judicial arguments like this in the future, why not let us sacrifice contraband to Dithmenos, and let him make the final determination? That's how Elyvilon does it! Why should we be limited to exterminating _organic_ sources of illumination? It could be argued that any creature capable of using a flame-bearing magic item could potentially qualify, at some later date, as a source of illumination, so while I go about that Cartesian culling of the numbers for which Dith rewards me, it stands to reason that he accept offerings of potentially unsafe doodads like that Rod of Clouds.

Unrelated: Hastur is a trite and overused name. Why not Harbooglechak? Harbooglechak is much better.
Additional Information
Tags No tags attached.
Attached Files png file icon immorality.png [^] (77,980 bytes) 2014-05-07 15:28

- Relationships

-  Notes
(0026088)
nicolae (reporter)
2014-05-08 07:21

"Additionally, fireflies, mounted or otherwise, despite regularly emitting light at me, do not please Dith any more than monsters not so endowed."

Fireflies don't actually have any in-game effect that's described as light, such as a halo or corona. Regarding as anathema every single possible item or monster that might conceivably be flavored as giving off light was how Dith was originally implemented, and it was a pain in the ass both in terms of determining each item specifically in the code and in terms of the player correctly deducing what was verboten.

"To settle judicial arguments like this in the future, why not let us sacrifice contraband to Dithmenos, and let him make the final determination?"

Item sacrificing is considered a tedious mechanic and so new gods aren't likely to get it as an option.

The main bug here is the Rod of Clouds, I think.
(0026091)
golthoon (reporter)
2014-05-08 09:42
edited on: 2014-05-08 10:14

Killdudesing for piety ISN'T tedious? Hitting 'p' on the occasional naughty item is no Sisyphean inconvenience, especially not when we have 'o' and Tab explicitly to avert tedium. And I'd like to meet the player who kills a firefly, a creature so named because it glows conspicuously, and DOESN'T raise an eyebrow when Dithmenos waves it off without ceremony.

I'm glad you agree that the way in which Dith's ecclesiastical semantics are implemented is inconsistent. Does Dithmenos has a divine definition of "illumination" which obsoletes ours? If he seeks to enact permanent https://www.youtube.com/watch?v=JurGajlyEew [^] throughout the dungeon, as is claimed, why doesn't this Draconian (no relation) agenda also include items, like other gods? Is it an easier solution to rename fireflies "brown marmorated stinkbugs of unusual size" to avoid this conflict, or can we just set isGlowing == YUP and carry on?

The Rod of Clouds is flagged as contraband, but neither earns penance when used in melee nor when evoking it creates flame clouds. Tested in wizmode.

(0026092)
nicolae (reporter)
2014-05-08 10:57
edited on: 2014-05-08 11:10

"Killdudesing for piety ISN'T tedious? Hitting 'p' on the occasional naughty item is no Sisyphean inconvenience..."

Killing things is the main focus of the game. Standing on things and praying is not. Quite a few devs have gone on record saying they don't particularly like item sacrificing as a god conduct anymore, and that's not likely to change no matter how verbose you get. Incidentally, Dithmenos also originally accepted corpse sacrifices, which were removed as soon as a better piety idea came along.

"Does Dithmenos has a divine definition of 'illumination' which obsoletes ours?"

Why, yes. Specifically, "any in-game effect that's described as light, such as a halo or corona". Maybe Dith's piety rules could be written better to explain that "beings that bright light to the dungeon" means actual light effects and not mere glowing, but like I said: the original implementation of Dith hated pretty much everything whose flavor described it as glowing, which included a long list of non-obvious things, such as freezing brands (which glow with a cold blue light when you wield them), holy wrath brands (which glow with divine radiance), as well as monsters like orange rats, (very) ugly things, spatial vortices and maelstroms, pearl dragons, eyes of draining, shining eyes, eyes of devastation, golden eyes, spectral things, Ice Fiends, electric golems, balls of lightning, and wretched stars, because all of those creatures are tagged with the M_GLOW_LIGHT or M_GLOW_RADIATION flags, which are checked by bool mons::glows_naturally() which was used in the original Dith piety rules. As far as I can tell, the flags are intended to keep a monster from being corona'd or turning invisible. Giant fireflies, for the record, are tagged with neither M_GLOW_LIGHT nor M_GLOW_RADIATION.

In other words, the game's existing "isGlowing" check checks a rather minor and non-obvious effect that still doesn't do what you want it to regarding fireflies.

Edit: That said, the Rod of Clouds thing is a bug.

(0026094)
golthoon (reporter)
2014-05-08 13:59

"Killing things is the main focus of the game" should be filed under guru wisdom.

I realize you've submitted a gob of vaults, and you feel like that entitles you to speak for the development team, but how about you don't? I don't dispute your development history of Dith or your list of objects which a layperson might consider light-emitting - I covered that in the issue description - and whereas I'm glad you consistently agree with me that there is disparity between what the game says and what the game does, you cannot convince me that fireflies do not light up.
(0026095)
nicolae (reporter)
2014-05-08 14:26
edited on: 2014-05-08 14:32

"you cannot convince me that fireflies do not light up."
They do. Just not in any specific way that particularly rankles Dithmenos.

Edit: I mean, I am seeing the disconnect here, but I think at this point the better solution, if any, is to adjust Dithmenos' description a bit to specify that the piety rules refer to more than mere glowing, rather than expanding Dith's piety rules to include "everything that could conceivably be perceived as glowing", because the latter was tried and rejected already.

(0026101)
MarvinPA (developer)
2014-05-08 19:33

As nicolae said, piety from sacrificing items to Dith isn't going to happen, and the light conduct isn't likely to be changed to be significantly more complex again. Fixed the issue of creating fire clouds from the rod of clouds not causing piety loss, thanks for reporting.
(0026109)
golthoon (reporter)
2014-05-09 08:34
edited on: 2014-05-09 08:35

I agree that the prior Zero Tolerance regime was absurd and unreasonable to implement. I have lampshaded that several times now. But FIREFLIES?


- Issue History
Date Modified Username Field Change
2014-05-07 15:28 golthoon New Issue
2014-05-07 15:28 golthoon File Added: immorality.png
2014-05-07 15:41 golthoon Issue Monitored: golthoon
2014-05-08 07:21 nicolae Note Added: 0026088
2014-05-08 09:42 golthoon Note Added: 0026091
2014-05-08 10:14 golthoon Note Edited: 0026091
2014-05-08 10:57 nicolae Note Added: 0026092
2014-05-08 11:09 nicolae Note Edited: 0026092
2014-05-08 11:10 nicolae Note Edited: 0026092
2014-05-08 13:59 golthoon Note Added: 0026094
2014-05-08 14:26 nicolae Note Added: 0026095
2014-05-08 14:32 nicolae Note Edited: 0026095
2014-05-08 19:33 MarvinPA Note Added: 0026101
2014-05-08 19:33 MarvinPA Status new => resolved
2014-05-08 19:33 MarvinPA Fixed in Branch => 0.15 development branch
2014-05-08 19:33 MarvinPA Resolution open => done
2014-05-08 19:33 MarvinPA Assigned To => MarvinPA
2014-05-09 08:34 golthoon Note Added: 0026109
2014-05-09 08:35 golthoon Note Edited: 0026109


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker