Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008507 [DCSS] Patches minor have not tried 2014-05-06 21:45 2014-05-15 04:26
Reporter 78291 View Status public  
Assigned To Reaver
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008507: Temporary corrosion
Description Situations that would have resulted in corrosion now give a temporary penalty to AC and weapon damage. Possibly the numbers need some changes (or to scale with monster HD) if early jellies are too hard to kill.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Replace-corrosion-with-a-temporary-effect.patch [^] (11,557 bytes) 2014-05-07 17:11 [Show Content]

- Relationships

-  Notes
(0026079)
78291 (developer)
2014-05-07 17:13

Added a new version that makes artefact weapons immune to the effects of the corrosion penalty and displays corroded rods correctly.
(0026161)
Reaver (developer)
2014-05-13 11:05

Some notes:

A) I really like this change, although maybe it should be like Drain and cure with XP instead of time. A few other developers also appear to.

B) Added to dev planning page ("under consideration") for 0.15

C) This patch, due to containing a duration, did not have a long shelf life and completely fails to apply currently. I would be willing to fix this if I knew it would go into Trunk after.
(0026174)
Reaver (developer)
2014-05-15 04:26

Pushed as of e31251231736, Thanks!

- Issue History
Date Modified Username Field Change
2014-05-06 21:45 78291 New Issue
2014-05-06 21:45 78291 File Added: 0001-Replace-corrosion-with-a-temporary-effect.patch
2014-05-06 22:38 MarvinPA Issue Monitored: MarvinPA
2014-05-07 01:17 wheals Issue Monitored: wheals
2014-05-07 17:10 78291 File Deleted: 0001-Replace-corrosion-with-a-temporary-effect.patch
2014-05-07 17:11 78291 File Added: 0001-Replace-corrosion-with-a-temporary-effect.patch
2014-05-07 17:13 78291 Note Added: 0026079
2014-05-13 11:05 Reaver Note Added: 0026161
2014-05-15 04:26 Reaver Note Added: 0026174
2014-05-15 04:26 Reaver Status new => resolved
2014-05-15 04:26 Reaver Fixed in Branch => 0.15 development branch
2014-05-15 04:26 Reaver Resolution open => done
2014-05-15 04:26 Reaver Assigned To => Reaver
2014-05-15 07:46 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker