Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008456 [DCSS] Patches feature N/A 2014-04-27 23:04 2014-05-26 05:39
Reporter PleasingFungus View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008456: Add new unrand: the Black Staff
Description In the long tradition of 'unrands that will get the user killed' (shield of the gong, maxwell's, etc), the Black Staff is a staff that gives a universal spell enhancer, plus 6 int & 6 mp. However, every spell cast while wielding the staff costs 2hp * spell mp cost, in addition to the normal spellcasting cost.

The staff itself is a +6 vampiric quarterstaff, which is a decent weapon, and has a pleasing thematic synergy with the casting cost.

Placeholder tiles are included.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Add-the-Hellbinder-s-staff.patch [^] (19,578 bytes) 2014-05-03 19:49 [Show Content]
? file icon 0001-Add-the-Hellbinder-s-Quarterstaff.patch [^] (19,909 bytes) 2014-05-06 05:08 [Show Content]

- Relationships

-  Notes
(0026006)
PleasingFungus (administrator)
2014-05-02 02:58

Added a new patch that renames the artefact to the 'quarterstaff of the Hellbinder', in response to understandable confusion about the weapon type.

It might be good to add this to the Hellbinder wizlab at a low likelihood (similarly to how the robe of clouds can show up in the Cloud Mage wizlab), but I'm nowhere proficient enough in vaultese to make that change.
(0026009)
Reaver (developer)
2014-05-02 05:18

Couple minor things:

I would prefer the name "Staff of the Hellbinder" but I can see the point if it has quarterstaff melee attacks.

Why does _spellcasting_god_conduct() remove the !crawl_state.is_god_acting()?

A) The refactoring of that function should be a separate commit.

B) I imagine it would fail with the Xom card.
(0026010)
PleasingFungus (administrator)
2014-05-02 05:26

_spellcasting_god_conduct() removes !crawl_state.is_god_acting() because the function is only called in one place (_spellcasting_side_effects()), which performs the check. It might be reasonable to move the check to the start of the function itself; I don't feel strongly about it either way.

I refactored the function because I'd thought it would be a good place to put the mana barbs code (sadly, not so). It didn't seem worth either pushing for a separate patch or reverting the refactoring; if you want to pull it out, however, I have no objections.
(0026011)
Reaver (developer)
2014-05-02 06:01
edited on: 2014-05-02 06:03

No need to make a new patch - just a separate commit. This can be done with git reset --soft and git adding things back manually, or I guess the committer could do it.

Oh, and I deleted the old patch since it was apparently outdated.

(0026015)
MarvinPA (developer)
2014-05-02 14:24

"Mana barbs" isn't a very good death message. Could just be "unholy magic"/"lifeforce drained by unholy magic" for terse/long perhaps?

1 HP per MP seems fine to me, especially considering that those it'll in theory be useful for will likely be conjurers or summoners.

In the description, "taken from the mana used every time its wielder casts a spell" should probably be "taken in addition to". Also the description ends with an ellipsis!
(0026027)
PleasingFungus (administrator)
2014-05-03 19:52

New patches with requested changes: fixed the description/death message, reduced hp/mp cost further (to 1:1), and pulled the _god_conduct change into a separate patch.

Concerned that the hp cost won't really be noticeable for anyone but deep elves, but I guess we'll see. It's easy enough to change back (or to some other value), of course.
(0026036)
Reaver (developer)
2014-05-04 08:09
edited on: 2014-05-04 08:15

PleasingFungus:

+ if (!crawl_state.is_god_acting())
+ return;

Should be

+ if (crawl_state.is_god_acting())
+ return;

I won't have time to test compile it this weekend, but since it's independent of the unrandart I'll push the refactoring patch by Tuesday or so.

Also deleted the old patch.

(0026060)
Reaver (developer)
2014-05-06 05:03
edited on: 2014-05-06 05:04

Deleted the refactoring patch, since it's in Trunk. I have a commit which puts the you.spellcasting_unholy() bit back in, but it's so trival I'll just paste the commit:

commit ddab296341753a4e66c3e086f82ce49c7b6f0a5c
Author: reaver <redact email because spammers>
Date: Mon May 5 22:43:06 2014 -0400

    Squahsable Hellbinder patch
    
    This patch add you.spellcasting_unholy() to the spell casting god
    conducts.

diff --git a/crawl-ref/source/spl-cast.cc b/crawl-ref/source/spl-cast.cc
index 03812b0..48e8b2b 100644
--- a/crawl-ref/source/spl-cast.cc
+++ b/crawl-ref/source/spl-cast.cc
@@ -844,7 +844,7 @@ static void _spellcasting_god_conduct(spell_type spell)
 
     const int conduct_level = 10 + spell_difficulty(spell);
 
- if (is_unholy_spell(spell))
+ if (is_unholy_spell(spell) || you.spellcasting_unholy())
         did_god_conduct(DID_UNHOLY, conduct_level);
 
     if (is_unclean_spell(spell))

(0026061)
PleasingFungus (administrator)
2014-05-06 05:08

Ha - I literally just finished making that same change myself!
(0026265)
PleasingFungus (administrator)
2014-05-26 05:39

Pushed in 6f959b73ab6b, thanks!

- Issue History
Date Modified Username Field Change
2014-04-27 23:04 PleasingFungus New Issue
2014-04-27 23:04 PleasingFungus File Added: 0001-Add-the-Black-Staff.patch
2014-05-02 02:55 PleasingFungus File Added: 0001-Add-the-quarterstaff-of-the-Hellbinder.patch
2014-05-02 02:58 PleasingFungus Note Added: 0026006
2014-05-02 05:18 Reaver Note Added: 0026009
2014-05-02 05:26 PleasingFungus Note Added: 0026010
2014-05-02 06:01 Reaver Note Added: 0026011
2014-05-02 06:02 Reaver File Deleted: 0001-Add-the-Black-Staff.patch
2014-05-02 06:03 Reaver Note Edited: 0026011
2014-05-02 14:24 MarvinPA Note Added: 0026015
2014-05-03 19:49 PleasingFungus File Added: 0001-Add-the-Hellbinder-s-staff.patch
2014-05-03 19:50 PleasingFungus File Added: 0001-Refactor-_spellcasting_side_effects.patch
2014-05-03 19:52 PleasingFungus Note Added: 0026027
2014-05-04 04:05 MarvinPA Issue Monitored: MarvinPA
2014-05-04 08:09 Reaver Note Added: 0026036
2014-05-04 08:15 Reaver File Deleted: 0001-Add-the-quarterstaff-of-the-Hellbinder.patch
2014-05-04 08:15 Reaver Note Edited: 0026036
2014-05-06 05:02 Reaver File Deleted: 0001-Refactor-_spellcasting_side_effects.patch
2014-05-06 05:03 Reaver Note Added: 0026060
2014-05-06 05:04 Reaver Note Edited: 0026060
2014-05-06 05:08 PleasingFungus File Added: 0001-Add-the-Hellbinder-s-Quarterstaff.patch
2014-05-06 05:08 PleasingFungus Note Added: 0026061
2014-05-26 05:39 PleasingFungus Note Added: 0026265
2014-05-26 05:39 PleasingFungus Status new => resolved
2014-05-26 05:39 PleasingFungus Fixed in Branch => 0.15 development branch
2014-05-26 05:39 PleasingFungus Resolution open => done
2014-05-26 05:39 PleasingFungus Assigned To => PleasingFungus
2014-12-22 00:00 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker