Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008455 [DCSS] Patches feature N/A 2014-04-27 22:14 2014-05-09 03:08
Reporter PleasingFungus View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008455: New unrand: Orange Crystal Plate
Description Loosely inspired by chat in ##crawl-dev with dpeg, this is a piece of unrand crystal plate that gives various spellcasting-themed bonuses. (Also loosely themed to oppose the effects of orange crystal statues - clarity versus confusion, sustab & +int versus int drain.)

Essentially, I think armour that encourages players to cast while wearing crystal plate is pretty funny.

Tiles are included, but they're placeholders - the inventory sprite in particular looks pretty bad when on the green 'equipped' background. Someone with a better image editing program might want to experiment with removing the alpha channel entirely.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Add-orange-crystal-plate.patch [^] (13,647 bytes) 2014-04-27 22:31 [Show Content]
? file icon 0004-Add-orange-crystal-plate.patch [^] (12,775 bytes) 2014-04-27 22:49 [Show Content]
? file icon 0005-Add-orange-crystal-plate.patch [^] (12,967 bytes) 2014-05-08 16:55 [Show Content]

- Relationships

-  Notes
(0025928)
Reaver (developer)
2014-04-27 22:25

Just some quick feedback: I don't like how Wiz just means that it takes less skill to cast in Crystal Plate. The reason I like this randart is that you want to cast DESPITE being in super heavy armor, and just adding a property which partially compensates for being in heavy armour undermines that a bit.

I would prefer if the armor gave Archmage (Yes probably a buff but it's effectively wild magic given this thing's EV penalty and losing Wiz). It encourages casting but it still forces you to completely deal with the amour's casting penalty.

The flavor is nice and I think this would be a net gain for the game even if it went in as-is, but I think it would be even more fun if the Wiz was replaced with Archmage.
(0025929)
PleasingFungus (administrator)
2014-04-27 22:32

Added a revised version of the initial patch that fixes some potential enum issues.

@reaver, I really like the archmage/wiz swap idea. MarvinPA notes that there's already two unrand armours with archmage, which is true, but I do think it fits really well here... I'll slap up an alternate patch with that swap in a moment.
(0025931)
PleasingFungus (administrator)
2014-04-27 22:42
edited on: 2014-04-27 22:50

Uploaded archmage version.

edit: ...that's the wrong version.

edit: okay, I think I got it this time. Feel free to delete the first, third & fourth patches. (Sorry!)

(0025932)
nicolae (reporter)
2014-04-28 05:42

I love the idea of a crystal plate armour that encourages spellcasting -- Archmagi-branded crystal plate armour is one of my favorite "gag" brand combinations. (I thought about proposing such an unrand a while back, but I never get around to that sort of thing these days.)
(0025979)
Bloax (reporter)
2014-04-30 08:05

Unrandarts are so rare and the gag of a "super caster" armour that just happens to be CPA is more than worth having even if it clashes with something else.
(0025996)
Reaver (developer)
2014-04-30 21:32

I think it would be better to change the Robe of Folly so that it does not have archmagi than to give this randart Wiz. I doesn't make sense for an interesting, double-sided randart to have different amount of upsides for different character builds.

(I would support changing the Robe of Folly even if there wasn't this conflict, although this conflict is what triggered the idea)
(0026000)
Bloax (reporter)
2014-05-01 09:59

The black staff (another fine unrandart) would also be the third unrandart weapon to have the vamp brand, but I'm not seeing any complaints there.
(0026096)
PleasingFungus (administrator)
2014-05-08 16:58

Added a new version of the patch, featuring the lovely tiles that Ontoclasm made a few days ago. (Based on the archmage version of the artefact, since general consensus seemed to be that it was the more interesting one.)
(0026106)
MarvinPA (developer)
2014-05-09 03:08

Renamed it to "orange crystal plate armour" for consistency with some other unrands ("salamander hide armour", "moon troll leather armour") and pushed, thanks for the patch! I considered reducing the intelligence bonus to put more focus on the Archmagi ego (and avoid the intelligence bonus making it much easier to cast in the same way that Wiz would have done, as reaver pointed out), may still do so later.

- Issue History
Date Modified Username Field Change
2014-04-27 22:14 PleasingFungus New Issue
2014-04-27 22:14 PleasingFungus File Added: 0001-Add-orange-crystal-armour.patch
2014-04-27 22:25 Reaver Note Added: 0025928
2014-04-27 22:31 PleasingFungus File Added: 0001-Add-orange-crystal-plate.patch
2014-04-27 22:32 PleasingFungus Note Added: 0025929
2014-04-27 22:42 PleasingFungus File Added: 0002-Add-orange-crystal-plate.patch
2014-04-27 22:42 PleasingFungus Note Added: 0025931
2014-04-27 22:42 PleasingFungus Note Edited: 0025931
2014-04-27 22:46 PleasingFungus File Added: 0003-Add-orange-crystal-plate.patch
2014-04-27 22:49 PleasingFungus File Added: 0004-Add-orange-crystal-plate.patch
2014-04-27 22:50 PleasingFungus Note Edited: 0025931
2014-04-27 23:08 wheals File Deleted: 0001-Add-orange-crystal-armour.patch
2014-04-27 23:08 wheals File Deleted: 0002-Add-orange-crystal-plate.patch
2014-04-27 23:08 wheals File Deleted: 0003-Add-orange-crystal-plate.patch
2014-04-28 05:42 nicolae Note Added: 0025932
2014-04-30 08:05 Bloax Note Added: 0025979
2014-04-30 08:25 MarvinPA Issue Monitored: MarvinPA
2014-04-30 21:32 Reaver Note Added: 0025996
2014-05-01 09:59 Bloax Note Added: 0026000
2014-05-08 16:55 PleasingFungus File Added: 0005-Add-orange-crystal-plate.patch
2014-05-08 16:58 PleasingFungus Note Added: 0026096
2014-05-09 03:08 MarvinPA Note Added: 0026106
2014-05-09 03:08 MarvinPA Status new => resolved
2014-05-09 03:08 MarvinPA Fixed in Branch => 0.15 development branch
2014-05-09 03:08 MarvinPA Resolution open => done
2014-05-09 03:08 MarvinPA Assigned To => MarvinPA
2014-05-15 07:46 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker