Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008430 [DCSS] Bug Report minor have not tried 2014-04-24 11:31 2015-06-06 02:07
Reporter conted View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008430: "Unlinked item held by dead monster" in Elf:3.
Description Killed a deep elf sorcerer and received the following message.

 Unlinked item held by dead monster:
 ring of teleport control
     item 0000051:  base: 6; sub: 23; plus: 0; plus2: 0; special: 249
     quant: 1; colour: 2; ident: 0x00000000; ident_type: 4
     x: -2; y: -2; link: 27028
 Unlinked item held by dead monster:
 cutlass of protection
     item 0000061:  base: 0; sub: 13; plus: 2; plus2: 5; special: 8
     quant: 1; colour: 3; ident: 0x00020002; ident_type: 0
     x: -2; y: -2; link: 27028
 Unlinked item held by dead monster:
 scale mail
     item 0000124:  base: 2; sub: 3; plus: 0; plus2: 0; special: 0
     quant: 1; colour: 11; ident: 0x00000100; ident_type: 0
     x: -2; y: -2; link: 27028
 Item ring of teleport control claims to be held by monster DEAD MONSTER, but it
 isn't in the monster's inventory.


The items mentioned were not found on the monsters corpse. There is nothing I did that I can think of that might have caused this.

Save: http://crawl.akrasiac.org/saves/lyke-crawl-0.14-140424-0529.tar.bz2 [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0008926closedneil Unlinked item held by dead monster 
related to 0009066closedneil Errors on zoning into Elf 3 
has duplicate 0008572closed Unlinked item report 
has duplicate 0009753resolvedPleasingFungus Unlinked item held by dead monster 
has duplicate 0009749closedneil Weird crash message with wielding the Glaive the Prune 
has duplicate 0009522closedneil Error message pop-up. Unknown if gameplay effect. 
has duplicate 0009503closedneil Unlinked item on O:4 
has duplicate 0009251closedneil Some monster inventory related messages popped up on death 

-  Notes
(0027579)
Lasty (developer)
2014-10-26 20:46

I've got a save with the issue on Depths:2
https://dobrazupa.org/saves/Lasty-crawl-git-cf82e137c1-141026-1944.tar.bz2 [^]

The issue happened after killing a Rakshasa after killing its clones. No other rakshasa-cloned monsters were visible, and the items don't appear to exist in any form.
(0028814)
TAS2012 (reporter)
2015-04-09 09:03

8572 is closed with "fixed in 0.16", does that mean that this whole group of issues is now fixed?
(0028816)
wheals (administrator)
2015-04-09 16:17

No, it was closed as a duplicate.
(0028817)
TAS2012 (reporter)
2015-04-09 16:24

OK, I see. Perhaps the wrong place to discuss this, but this line is somewhat misleading (to me):
2014-09-07 00:38 doy Fixed in Branch => 0.16 development branch
(from the 8572 issue history)
(0029048)
neil (administrator)
2015-05-12 05:51

MgDark got a similar error in 0.16:
    https://dobrazupa.org/saves/MgDark-crawl-0.16-150512-0349.tar.bz2 [^]

Unlinked item held by dead monster:
long sword
      item 0000029:  base: 0; sub: 15; plus: -1; plus2: 0; special: 0
      quant: 1; ident: 0x20000102; ident_type: 0
      x: -2; y: -2; link: 27011
(0029099)
ldf (reporter)
2015-05-24 01:27

Got this in 0.17-a0-1115-g0372368:
http://crawl.develz.org/saves/dumps/ldf-0372368-150523-2326.tar.bz2 [^]

Unlinked item held by dead monster:
 potion of berserk rage
     item 0000044: base: 7; sub: 23; plus: 0; plus2: 0; special: 18
     quant: 1; ident: 0x00000000; ident_type: 4
     x: -2; y: -2; link: 27041
 Unlinked item held by dead monster:
 small agate ring
     item 0000045: base: 6; sub: 13; plus: 0; plus2: 0; special: 217
     quant: 1; ident: 0x20000000; ident_type: 0
     x: -2; y: -2; link: 27041
 Unlinked item held by dead monster:
 great sword of flaming
     item 0000112: base: 0; sub: 17; plus: 1; plus2: 0; special: 1
     quant: 1; ident: 0x20020002; ident_type: 0
     x: -2; y: -2; link: 27041
 You have identified the last potion.
 Item potion of berserk rage claims to be held by monster DEAD MONSTER, but it
 isn't in the monster's inventory.
(0029112)
argonaut (reporter)
2015-05-28 23:39

Crawl version 0.17-a0-1133-gfb1399f

The fireball engulfs the spriggan defender.
 You kill the spriggan defender!
 Unlinked item held by dead monster:
 trident of protection
     item 0000038: base: 0; sub: 24; plus: 5; plus2: 0; special: 8
     quant: 1; ident: 0x20010002; ident_type: 0
     x: -2; y: -2; link: 27083
 Unlinked item held by dead monster:
 ring of wizardry
     item 0000051: base: 6; sub: 16; plus: 0; plus2: 0; special: 330
     quant: 1; ident: 0x20000000; ident_type: 4
     x: -2; y: -2; link: 27083
 Unlinked item held by dead monster:
 robe
     item 0000110: base: 2; sub: 0; plus: 0; plus2: 0; special: 0
     quant: 1; ident: 0x20000000; ident_type: 0
     x: -2; y: -2; link: 27083
 Item ring of wizardry claims to be held by monster DEAD MONSTER, but it isn't in the monster's inventory.

I can post the .cs file if it's helpful.
(0029113)
PleasingFungus (administrator)
2015-05-28 23:47

It probably won't be helpful, but you can post it if you'd like.
(0029144)
neil (administrator)
2015-06-06 02:07
edited on: 2015-06-06 02:07

Fixed in trunk (0.17-a0-1255-gd996e2d) and stable (0.16.1-29-g3e760ad), thanks! This fixes only the Ashenzari version of the problem: there is still some other bug related to Beogh with similar results (0008187), and the oldest report of these symptoms (0007983) is mysterious because it involved Nemelex instead.


- Issue History
Date Modified Username Field Change
2014-04-24 11:31 conted New Issue
2014-09-07 00:43 doy Relationship added has duplicate 0008572
2014-09-10 08:50 PleasingFungus Relationship added related to 0008926
2014-10-22 16:04 wheals Relationship added related to 0009066
2014-10-26 20:46 Lasty Note Added: 0027579
2014-11-19 14:14 wheals Relationship added related to 0009225
2015-04-09 09:03 TAS2012 Note Added: 0028814
2015-04-09 16:17 wheals Note Added: 0028816
2015-04-09 16:24 TAS2012 Note Added: 0028817
2015-05-12 05:51 neil Note Added: 0029048
2015-05-24 01:27 ldf Note Added: 0029099
2015-05-28 23:39 argonaut Note Added: 0029112
2015-05-28 23:47 PleasingFungus Note Added: 0029113
2015-06-03 19:51 Dharmy Issue Monitored: Dharmy
2015-06-03 23:28 PleasingFungus Relationship added has duplicate 0009753
2015-06-06 01:50 neil Relationship added has duplicate 0009749
2015-06-06 01:53 neil Relationship deleted related to 0009225
2015-06-06 01:54 neil Relationship added has duplicate 0009522
2015-06-06 01:55 neil Relationship added has duplicate 0009503
2015-06-06 01:56 neil Relationship added has duplicate 0009251
2015-06-06 02:07 neil Note Added: 0029144
2015-06-06 02:07 neil Status new => resolved
2015-06-06 02:07 neil Fixed in Branch => 0.17 development branch
2015-06-06 02:07 neil Resolution open => done
2015-06-06 02:07 neil Assigned To => neil
2015-06-06 02:07 neil Note Edited: 0029144


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker