Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008429 [DCSS] Bug Report crash always 2014-04-24 09:33 2014-06-05 23:44
Reporter Prevail View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008429: Crash in Spider Nest
Description I've been getting this aggravating crash while in the Spider Nest branch. Causes a complete crash of the game. It is sporadic and has happened without any apparent cause.

Playing NaSk of Makhleb if that matters.

I hope this is easily fixable because this is the only naga I've gotten anywhere past lair with.

I attached a screenshot. I'd attach my save file and crash data but it says I can 'attach other files later', not sure what that means.
Additional Information
Tags No tags attached.
Attached Files png file icon dark souls 2 isn't released yet so I'm playing crawl but crawl is crashing so fuuuuuuuuckkkkkkkk.png [^] (451,467 bytes) 2014-04-24 09:33
? file icon Kormenpacer.cs [^] (967,561 bytes) 2014-04-24 09:35
txt file icon crash-Kormenpacer-20140424-173445.txt [^] (49,766 bytes) 2014-04-24 09:35 [Show Content]

- Relationships
has duplicate 0008394resolvedneil Crash 
has duplicate 0008650closedneil "Invalid Trap Type 100" crash on Spider Nest 5 

-  Notes
(0025902)
Prevail (reporter)
2014-04-24 09:35

There we go, uploaded the crash and save file. Tell me if you need anything else.
(0025903)
floatingatoll (reporter)
2014-04-24 10:54

Does it crash every time you load the game, or can you load and resume?

Notes for the bug --

The screenshot says:

ERROR in 'directn.cc' at line 2977: Error: invalid trap type 100

which is in the case statement at the top of _base_feature_desc():

static string _base_feature_desc(dungeon_feature_type grid, trap_type trap)
  {
      if (feat_is_trap(grid) && trap != NUM_TRAPS)
      {
          switch (trap)
          {
          ...
          default:
              die("Error: invalid trap type %d", trap);


enum.h says 100 is TRAP_UNASSIGNED, which is unhandled by previously-mentioned case statement:

enum trap_type
{
  ...
  TRAP_UNASSIGNED = 100
  ...
}


The log shows a lot of trapdoor spiders, probably because level Spider:5, which made me think of this chunk in stash.cc function Stash::update() where a TRAP_WEB is converted to TRAP_UNASSIGNED for some reason:

      if (feat_is_trap(feat))
      {
          trap = get_trap_type(p);
          if (trap == TRAP_WEB)
              feat = DNGN_FLOOR, trap = TRAP_UNASSIGNED;
(0025904)
Prevail (reporter)
2014-04-24 11:10

I can load and resume, but it eventually crashes.
(0025910)
Taxman66 (reporter)
2014-04-24 18:31

This is the same error I get/got in bug report 8394.

You can power through the level eventually by just saving often. The crashes are random and not repeatable by taking the same moves.
(0025920)
Mathosse-Feadur (reporter)
2014-04-27 02:05

Same issue than my crash 0008451.

Looks like it's specific to the spider nest, I got it in spider nest 4
(0026126)
sgaspam (reporter)
2014-05-10 23:43
edited on: 2014-05-11 16:36

I am getting the same crash on spider nest 4 as well. (EDIT: See my next comment for more information on reproducing this bug)

(0026127)
floatingatoll (reporter)
2014-05-11 00:53

As a side note, if anyone has a backtrace from a crash on Linux/Mac or one of the webtiles sites, please add that information to the bug - it's missing from the original report and I've had no luck repro'ing from save files on my own.
(0026137)
sgaspam (reporter)
2014-05-11 16:26

I can add more information on this bug. What I found is that it relates somehow to the mouse moving over the main adventure screen window. When I resolutely keep it to the right over the character overview and command tabs then the crashes go away. If I move the mouse over the main adventure screen rapidly it will crash almost immediately.
(0026163)
bestogre (reporter)
2014-05-13 16:50

Is there any fix?
(0026166)
neil (administrator)
2014-05-13 21:11
edited on: 2014-05-13 21:15

This should be fixed in trunk now (0.15-a0-805-g7ebe137), thanks!

Edit: And stable (0.14.1-2-gf595e19).

(0026172)
Denniz (reporter)
2014-05-14 23:00

Does the current 0.14.1 window tiles download include the fix? I downloaded 0.14.1 again today to be sure I had the latest.

I am getting the error: "ERROR in 'directn.cc' at line 2977: Error: invalid trap type 100" in Spider's Nest. At least a half dozen times already.
(0026397)
neil (administrator)
2014-06-05 23:44

Denniz: No, 0.14.1 doesn't have the fix, but 0.14.2 will.

- Issue History
Date Modified Username Field Change
2014-04-24 09:33 Prevail New Issue
2014-04-24 09:33 Prevail File Added: dark souls 2 isn't released yet so I'm playing crawl but crawl is crashing so fuuuuuuuuckkkkkkkk.png
2014-04-24 09:35 Prevail File Added: Kormenpacer.cs
2014-04-24 09:35 Prevail File Added: crash-Kormenpacer-20140424-173445.txt
2014-04-24 09:35 Prevail Note Added: 0025902
2014-04-24 10:54 floatingatoll Note Added: 0025903
2014-04-24 11:10 Prevail Note Added: 0025904
2014-04-24 18:31 Taxman66 Note Added: 0025910
2014-04-27 02:05 Mathosse-Feadur Note Added: 0025920
2014-05-10 23:43 sgaspam Note Added: 0026126
2014-05-11 00:53 floatingatoll Note Added: 0026127
2014-05-11 16:26 sgaspam Note Added: 0026137
2014-05-11 16:36 sgaspam Note Edited: 0026126
2014-05-13 16:50 bestogre Note Added: 0026163
2014-05-13 21:03 neil Status new => assigned
2014-05-13 21:03 neil Assigned To => neil
2014-05-13 21:11 neil Note Added: 0026166
2014-05-13 21:11 neil Status assigned => resolved
2014-05-13 21:11 neil Fixed in Branch => 0.15 development branch
2014-05-13 21:11 neil Resolution open => done
2014-05-13 21:15 neil Note Edited: 0026166
2014-05-13 21:15 neil Fixed in Branch 0.15 development branch => 0.14 stable branch
2014-05-14 23:00 Denniz Note Added: 0026172
2014-05-17 22:33 neil Relationship added has duplicate 0008394
2014-06-05 23:42 neil Relationship added has duplicate 0008650
2014-06-05 23:44 neil Note Added: 0026397


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker