Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008407 [DCSS] Bug Report minor always 2014-04-21 22:28 2014-05-19 19:59
Reporter Skrybe View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008407: +9 weapons listed as valid ?EW targets, waste scroll
Description If a weapon is at +9 accuracy or damage, but not both, it will still be displayed as a valid target for ?EW. For example, I have a +9,+5 eveningstar that still accepts ?EWI, wasting the scroll. Since weapons at +9,+9 are no longer valid targets for ?EW, and same for maxed out armor and ?EA, I'm assuming this isn't the intended behavior.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0008552resolvedneil not cursed +9 blowguns show on the list for enchantment 

-  Notes
(0025889)
ion_frigate (reporter)
2014-04-23 04:08

There's a slight issue in that a scroll of EW will uncurse a +9 weapon, so it isn't useless all the time.
(0025892)
Skrybe (reporter)
2014-04-23 05:03

Yeah, but a +9,+9 weapon, a maxed piece of armor, or an artifact won't show on the list of valid targets for an enchant scroll normally, but that changes if it gets cursed. Ideally, the situation I gave above should do the same.
(0026164)
neil (administrator)
2014-05-13 20:43

Fixed in trunk (0.15-a0-804-gfd921b9), thanks!

- Issue History
Date Modified Username Field Change
2014-04-21 22:28 Skrybe New Issue
2014-04-23 04:08 ion_frigate Note Added: 0025889
2014-04-23 05:03 Skrybe Note Added: 0025892
2014-05-13 20:43 neil Note Added: 0026164
2014-05-13 20:43 neil Status new => resolved
2014-05-13 20:43 neil Fixed in Branch => 0.15 development branch
2014-05-13 20:43 neil Resolution open => done
2014-05-13 20:43 neil Assigned To => neil
2014-05-13 20:44 neil Relationship added related to 0008552
2014-05-19 19:59 Skrybe Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker