Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008398 [DCSS] Bug Report minor N/A 2014-04-19 11:40 2014-08-02 10:36
Reporter dtsund View Status public  
Assigned To doy
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008398: Hitting plants with a chaos weapon is a failsafe way to amuse Xom
Description Xom is highly amused when a chaos weapon heals your target. He doesn't particularly care if it's a target capable of hitting back.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0008633resolvedPleasingFungus Xom entertained by hitting plants with chaos weapon 

-  Notes
(0025868)
Sar (reporter)
2014-04-20 11:23

IIRC you can poly a plant into an oklob plant, so it's not 100% safe.
(0026608)
PleasingFungus (administrator)
2014-06-23 07:11

There's code which specifically is supposed to prevent this, but it still happens, along with autopickup being disabled when plants become invisible. Possibly the latter should be a separate bug.
(0026683)
golthoon (reporter)
2014-07-04 13:57

Related to 0008633 .
(0026895)
doy (developer)
2014-08-02 10:36

Fixed in 65b51e3. I couldn't reproduce plants disabling autopickup when turning invisible. Autopickup is disabled when you hit the invisible plant, but I think that's consistent with invisibility meaning that you don't actually know what's there (a different invisible monster could have killed it and took its place, for instance).

- Issue History
Date Modified Username Field Change
2014-04-19 11:40 dtsund New Issue
2014-04-20 11:23 Sar Note Added: 0025868
2014-06-23 07:11 PleasingFungus Note Added: 0026608
2014-07-04 13:57 golthoon Note Added: 0026683
2014-07-04 18:36 PleasingFungus Relationship added has duplicate 0008633
2014-08-02 10:36 doy Note Added: 0026895
2014-08-02 10:36 doy Status new => resolved
2014-08-02 10:36 doy Fixed in Branch => 0.15 development branch
2014-08-02 10:36 doy Resolution open => done
2014-08-02 10:36 doy Assigned To => doy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker