Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008392 [DCSS] Bug Report minor have not tried 2014-04-18 22:38 2014-05-20 22:42
Reporter ebarrett View Status public  
Assigned To Reaver
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008392: Being unwillingly polymorphed into a bat as a vampire while full gets you permanently stuck in bat form
Description I was playing a Vp and had just acquired the ability to turn into a bat, but upon noticing I wasn't too keen on flying around the dungeon without my opposing thumbs, some random goblin with a wand of polymorph went ahead and zapped me with it, turning me into, of all things, yes, a bat.

I contemplated the irony of the situation for a moment before flying away at bat-speed to wait out the bat-transformation, but after tapping the '5' key a few times, I was certainly not done waiting, despite the game's insistence on telling me so. Unfluttered by this unexpected inconvenience, I thought it could be just a matter of cancelling the transformation myself; being a bat is, after all, part of a vampire's nature, and as such, so is being a not-bat when currently one and not wanting to anymore.

Alas, having recently feasted on the blood of my fallen enemies, apparently I was in no condition to control my bat-whims, or in this case, my not-bat-whims. "No problem", I thought; "I'll just '5' until I'm a bit more dead". While the game misinterpreted that, and started tried to shove me downwards by spawning progressively nastier critters, I did manage to reduce my satiation to a bat-appropriate level without much trouble.

To my horror, however, quoth the raven, "Sorry, you're too full to transform right now". Well, I guess it wasn't really a raven, unless one of the developers happens to be one, something I really doubt; ravens are smart birds but I think most programming courses in civilized countries do not accept birds as students (I'd rather not consider the thought of a self-taught programmer raven). But whomever it was, the same message greeted me ever and ever again, until, disgusted by the ordeal, I left the dungeon, trapped in batdom until the Apocalypse arrives.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026240)
Reaver (developer)
2014-05-20 22:03

I used polymorph on myself in Wizmode as a Vampire until I turned into a bat, I could not reproduce this issue.
(0026241)
Reaver (developer)
2014-05-20 22:08

Reopenned because MarvinPA said he reproduced this via a different method.
(0026242)
neil (administrator)
2014-05-20 22:42

Fixed for real this time (0.15-a0-934-g58b8beb and 0.14.1-8-gf0777f1). Thanks for your patience :)

- Issue History
Date Modified Username Field Change
2014-04-18 22:38 ebarrett New Issue
2014-05-20 22:03 Reaver Note Added: 0026240
2014-05-20 22:03 Reaver Status new => resolved
2014-05-20 22:03 Reaver Fixed in Branch => 0.15 development branch
2014-05-20 22:03 Reaver Resolution open => unable to reproduce
2014-05-20 22:03 Reaver Assigned To => Reaver
2014-05-20 22:08 Reaver Note Added: 0026241
2014-05-20 22:08 Reaver Status resolved => new
2014-05-20 22:08 Reaver Resolution unable to reproduce => reopened
2014-05-20 22:42 neil Note Added: 0026242
2014-05-20 22:42 neil Status new => resolved
2014-05-20 22:42 neil Fixed in Branch 0.15 development branch => 0.14 stable branch
2014-05-20 22:42 neil Resolution reopened => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker