Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008365 [DCSS] Upload: Maps and Vaults feature have not tried 2014-04-10 00:18 2014-05-10 10:40
Reporter Cheibrodos View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008365: More Vaults
Description Practicing with new locations and features. Helpful feedback is always appreciated. Comments in file.
Additional Information
Tags No tags attached.
Attached Files txt file icon vaults2.txt [^] (7,797 bytes) 2014-04-10 00:18 [Show Content]
txt file icon cheibrodos_poisonous_passages.txt [^] (2,112 bytes) 2014-05-10 04:40 [Show Content]

- Relationships

-  Notes
(0026093)
gammafunk (administrator)
2014-05-08 11:11
edited on: 2014-05-08 11:12

All vaults with the exception of cheibrodos_poisonous_passages were pushed with some minor modifications in 0.15-a0-652-g23cdfa8, thanks!

For cheibrodos_shoals_oceanic_diplomacy, I placed the entry points near each door, armed the ordinary octopodes, and gave the diplomats some nice equipment.

I thinned out the salamanders in cheibrodos_snake_lava_hold only very slightly and added the patrolling tag; I don't think the encounter is way out of the ordinary in terms of how many N you're fighting and given that there's some nice loot, but others might disagree

Other minor cleanups: no_pool_fixup for cheibrodos_snake_ritualist_ritual and consistent use of ":" in NSUBST (instead of mixing = and :). The syntax file says that doors on the edge of a vault are always considered entry points, so it seems that any @ in cheibrodos_snake_lava_hold are not needed, but I learned this after pushing the commit.

Feel free to upload a new cheibrodos_poisonous_passages in this report based on our discussion of the problems with that vault.

(0026119)
Cheibrodos (reporter)
2014-05-10 04:43

I added an updated version of poisonous_passages. I went through some of the others, and the shoals vaults keep placing strangely like we talked about. I think it's safe to say that shoals is weird and I'm not sophisticated enough to figure it out. I'm not sure how to fix them.
(0026122)
gammafunk (administrator)
2014-05-10 10:40

Pushed in 0.15-a0-730-g8fb6756, thanks.

The only content adjustment I made was to reduce the loot from 7 to 4 items per type. Seven acquire-level items and seven good items is closer to what we give in e.g. crypt ends, which there are much larger numbers of enemies. We could put in some gold piles if you feel strongly that the loot is too minimal.

The crawl.random2(N) function returns a value in [0,N), so [0,14] in your case, hence I changed the cutoffs to use <= so as to give equal weighting to each, monster set, since that seemed to be your intention.

The only other cleanups were to using no_rtele_into instead of no_ctele_into (preventing cteles isn't necessary, only random ones), and to clean up the indent of multiline MONS statements.

- Issue History
Date Modified Username Field Change
2014-04-10 00:18 Cheibrodos New Issue
2014-04-10 00:18 Cheibrodos File Added: vaults2.txt
2014-05-08 11:11 gammafunk Note Added: 0026093
2014-05-08 11:12 gammafunk Note Edited: 0026093
2014-05-10 04:40 Cheibrodos File Added: cheibrodos_poisonous_passages.txt
2014-05-10 04:43 Cheibrodos Note Added: 0026119
2014-05-10 10:40 gammafunk Note Added: 0026122
2014-05-10 10:40 gammafunk Status new => resolved
2014-05-10 10:40 gammafunk Fixed in Branch => 0.15 development branch
2014-05-10 10:40 gammafunk Resolution open => done
2014-05-10 10:40 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker