Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008337 [DCSS] Patches feature N/A 2014-03-31 02:49 2014-05-05 22:33
Reporter Lasty View Status public  
Assigned To elliptic
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0008337: Fixing wanderer starting kit
Description So, wanderers start with at least three "items", based off their skills, one "good" and two "decent". The list of "decent" items seems fairly solid to me, but I think the "good" list could use work. Here's what it is right now:

Take a (weighted) random skill the wanderer has and do give an item based on it:
Fighting/Weapon skill: +1-3, +1-3 starting weapon of the chosen type.
Magic skill: an appropriate spellbook.
Shield skill: a +0 buckler
Dodging, Stealth, UC, Invo: 2x attempts to get curing or teleport and a good potion or scroll (from a list)
Evocations: a random low-level wand (from a list)
Armour skill: +0 scale mail

It seems to me that if Fighting/Weapon is chosen, you get something very good, ranging up to possibly a +3/+3 crossbow or quarterstaff, whereas if Armour is chosen, you get something significantly worse. Some of the other skills give something of good power level, but maybe not as apropos as possible, like Dodging and perhaps Stealth.

Here's what I've changed. No one suggested anything different in the forum, but many liked what I proposed.

Weapon skill: +1-3/+1-3 short sword|mace|hand axe|blowgun|spear|falchion or +1-2/+1-2 bow or +1/+1 quarterstaff|crossbow.
Armour skill: +1-2 scale mail armour or (+0 scale mail armour and +0 helmet)
Dodging skill: +1-2 leather armour or +0 cloak
Stealth skill: +2-3/+2-3 dagger or 2-4 nets

I've tested this patch by compiling and generating wanderers until I saw each case come up.
Additional Information
Tags No tags attached.
Attached Files ? file icon test.patch [^] (3,055 bytes) 2014-03-31 02:49 [Show Content]
? file icon wanderer_v2.patch [^] (10,466 bytes) 2014-04-02 04:31 [Show Content]

- Relationships

-  Notes
(0025753)
elliptic (developer)
2014-03-31 03:11

I don't see a good reason to special-case different weapon skills and give them different bonuses -- sure, some of those weapons are better than others, but wanderers aren't supposed to all be the same power level and this feels like unnecessary complication to me.

I also don't like the dodging/stealth changes -- I don't think they will play as well as giving out consumables. Being more "apropos" is not a convincing argument given that players aren't going to be aware that they are associated with dodging/stealth inside the code.

I do think boosting the armour skill gift is a good idea though, since +0 scale mail and nothing else is quite weak and also boring. Enchantment, a chance at starting with ring or chain instead, or a piece of auxiliary armour all seem reasonable to me.
(0025754)
elliptic (developer)
2014-03-31 03:14

Oh, I also think the Shields skill gift could use a change - +0 buckler is really lame for most species, and giving a regular shield instead for non-small species would be good (like fighter does).
(0025755)
Lasty (developer)
2014-03-31 03:34

FWIW, +0 shield is already the SK_SHIELDS good_item. The decent_item is +0 buckler. I think it may be possible for ogres/trolls to get bucklers.
(0025756)
Lasty (developer)
2014-03-31 03:39

Tavern post was https://crawl.develz.org/tavern/viewtopic.php?f=8&t=11388 [^]

in ##crawl-dev, I believe elliptic suggested:
* keep all weapons at +1-3
* make dodging good_item either +1-3 leather or +0 leather and throwing nets
* keep Stealth good_item as a consumable
(0025757)
elliptic (developer)
2014-03-31 03:40

Apparently Shields skill does already try to give a regular shield, so that is probably fine.

After some discussion on IRC, my current suggestions are to make the weapons +1-2 instead of +1-3, change Dodging skill to either give +0 leather and nets or give +1-2 leather, and leave Stealth skill as it is (giving consumables).
(0025758)
Lasty (developer)
2014-03-31 13:20

Does it make sense to upgrade the list of good_item weapons to use the new Fighter list? If so, it would be reasonable to cap all at +1. It would make the weapon list slightly more even and add more variety in what wanderers can start with, which both seem like good things to me.
(0025759)
Lasty (developer)
2014-03-31 17:36
edited on: 2014-03-31 17:41

After further discussion w/ elliptic, I think this is what we've come up with. Hopefully elliptic will note if I've gotten any point wrong:
* All good_equipment weapons will be exactly +2.
* Good_equipment Dodging is +2 leather or +0 leather and 2-4 nets.
* Good_equipment Armour is +2 scale.
* Good_equipment UC is 2 good consumables instead of 1. (this may be a bug?)
* Good_equipment Stealth is 1 good consumable and +2 dagger.
* Remove Invo as a starting skill.
* Decent_equipment UC/Dodging/Stealth will give 1 of [!curing, ?tele, !lignification] at random instead of giving nothing at all.
* Decent_equipment Evo will give wand of random effects instead of nothing at all.

(0025766)
Lasty (developer)
2014-04-02 04:34

Uploaded a revised patch. In testing, I found that the existing code can place two separate instances of the same consumable in two inventory slots, so I fixed that.

I observed all skill cases in testing, though I found that in one case Polearms Good and Hexes/Summoning Descent gave only a +2 spear. I didn't figure out the source of that issue, but it seems to be both extremely rare and preexisting, so I'm going to upload this patch anyway.
(0026055)
elliptic (developer)
2014-05-05 22:33

In master now, thanks!

- Issue History
Date Modified Username Field Change
2014-03-31 02:49 Lasty New Issue
2014-03-31 02:49 Lasty File Added: test.patch
2014-03-31 03:11 elliptic Note Added: 0025753
2014-03-31 03:14 elliptic Note Added: 0025754
2014-03-31 03:34 Lasty Note Added: 0025755
2014-03-31 03:39 Lasty Note Added: 0025756
2014-03-31 03:40 elliptic Note Added: 0025757
2014-03-31 13:20 Lasty Note Added: 0025758
2014-03-31 17:36 Lasty Note Added: 0025759
2014-03-31 17:40 Lasty Note Added: 0025760
2014-03-31 17:40 Lasty Note Deleted: 0025760
2014-03-31 17:41 Lasty Note Edited: 0025759
2014-04-02 04:31 Lasty File Added: wanderer_v2.patch
2014-04-02 04:34 Lasty Note Added: 0025766
2014-05-05 22:33 elliptic Note Added: 0026055
2014-05-05 22:33 elliptic Status new => resolved
2014-05-05 22:33 elliptic Fixed in Branch => 0.15 development branch
2014-05-05 22:33 elliptic Resolution open => done
2014-05-05 22:33 elliptic Assigned To => elliptic


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker