Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008327 [DCSS] Patches feature N/A 2014-03-28 03:01 2014-09-23 22:17
Reporter nrook View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0008327: New trove type, takes your piety when you enter
Description It's the implementation of https://crawl.develz.org/tavern/viewtopic.php?f=8&t=11266&start=50; [^] a special trove, only for atheists, that resets your piety to 15 when you enter.

So-called "nopiety troves" support the v" portal debug interface, so to test them, make a trove in debug mode and use v" to switch it to a trove that takes piety.
Additional Information
Tags No tags attached.
Attached Files ? file icon nopiety-trove-4.patch [^] (22,772 bytes) 2014-03-28 05:46 [Show Content]
? file icon nopiety-trove-5.patch [^] (26,050 bytes) 2014-09-21 21:53 [Show Content]

- Relationships

-  Notes
(0025743)
nrook (updater)
2014-03-28 05:46

New version vetoes the nopiety trove for demigods.
(0025744)
Reaver (developer)
2014-03-28 18:19

Deleted attachment nopiety-trove-3.patch, since nopiety-trove-4.patch is the same except with the demigod update.
(0027352)
wheals (administrator)
2014-09-23 22:17

Squashed the rebased version and pushed; thanks for the patch!

- Issue History
Date Modified Username Field Change
2014-03-28 03:01 nrook New Issue
2014-03-28 03:01 nrook File Added: nopiety-trove-3.patch
2014-03-28 05:46 nrook Note Added: 0025743
2014-03-28 05:46 nrook File Added: nopiety-trove-4.patch
2014-03-28 18:18 Reaver File Deleted: nopiety-trove-3.patch
2014-03-28 18:19 Reaver Note Added: 0025744
2014-04-03 16:26 MarvinPA Issue Monitored: MarvinPA
2014-09-21 21:53 nrook File Added: nopiety-trove-5.patch
2014-09-23 22:17 wheals Note Added: 0027352
2014-09-23 22:17 wheals Status new => resolved
2014-09-23 22:17 wheals Fixed in Branch => 0.16 development branch
2014-09-23 22:17 wheals Resolution open => done
2014-09-23 22:17 wheals Assigned To => wheals
2014-12-22 00:00 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker