Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008323 [DCSS] Bug Report minor always 2014-03-27 18:01 2014-05-19 13:20
Reporter Kvaak View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008323: Red draconian breath doesn't replace/remove fire breath mutation.
Description Gaining the fire breath mutation and then turning into a red draconian results in two abilities with the exact same name and keybind appearing in your abilities. Breathing fire creates a cloud of fire, i.e. the red draconian version is used, not the random mutation.

To reproduce enter wizmode, get the fire breath mutation and change your species into red draconian.

As far as I know this applies only to red draconians since the random poisonous breath mutation and green draconian one have different names.

Attached a save file with the aforementioned bug.
(FR: dual breath)
Additional Information
Tags No tags attached.
Attached Files png file icon doublebreath.png [^] (43,083 bytes) 2014-03-27 18:02

- Relationships

-  Notes
(0026203)
wheals (administrator)
2014-05-18 23:25

Should be fixed with commit d77aa5a.

- Issue History
Date Modified Username Field Change
2014-03-27 18:01 Kvaak New Issue
2014-03-27 18:02 Kvaak File Added: doublebreath.png
2014-05-18 23:25 wheals Note Added: 0026203
2014-05-18 23:25 wheals Status new => resolved
2014-05-18 23:25 wheals Fixed in Branch => 0.15 development branch
2014-05-18 23:25 wheals Resolution open => done
2014-05-18 23:25 wheals Assigned To => wheals
2014-05-19 13:20 Kvaak Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker