Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008306 [DCSS] Bug Report minor have not tried 2014-03-23 21:34 2015-05-09 08:06
Reporter brendan View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008306: Wands not IDd when used by monster
Description Sigmund zapped me with a wand of slowing and I failed to resist it. After killing him, the wand was still un-ID'd and annotated 'Zapped: 1'.

I would expect the wand to be ID'd in this situation.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026785)
neil (administrator)
2014-07-19 07:11

Was Sigmund invisible when the wand affected you? Crawl won't identify the wand in that case because, for all you know, there could have been *another* invisible monster zapping you with a different wand.

On the other hand, it shouldn't say "Zapped: 1" if you never saw it being zapped.
(0029024)
PleasingFungus (administrator)
2015-05-09 08:06

Fixed by 0df7b3ee54, thanks!

- Issue History
Date Modified Username Field Change
2014-03-23 21:34 brendan New Issue
2014-07-19 07:11 neil Note Added: 0026785
2015-05-09 08:06 PleasingFungus Note Added: 0029024
2015-05-09 08:06 PleasingFungus Status new => resolved
2015-05-09 08:06 PleasingFungus Fixed in Branch => 0.16 pre-release branch
2015-05-09 08:06 PleasingFungus Resolution open => done
2015-05-09 08:06 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker