Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008292 [DCSS] Implementables feature N/A 2014-03-20 01:22 2014-03-21 10:35
Reporter MarvinPA View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0008292: Generate card and deck lists instead of listing them manually in description database
Description Currently every deck has a list of the cards it contains in its description in items.txt ("It may contain the following cards: Vitriol, Flame, Frost, Venom, the Spark, the Hammer, Pain, the Orb." for decks of destruction, for example), and every card has a list of the decks that contain it in cards.txt ("It is usually found in decks of defence, escape and war." for the Banshee card).

These lists frequently become out-of-date when cards and decks are moved around, especially since moving a card from one pure deck to another may affect its existence in multiple decks such as changes, war and defence. The lists should instead be generated in describe.cc and appended to deck/card descriptions, similar to weapon stats.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0025658)
sgrunt (administrator)
2014-03-20 02:31

Not to step on the toes of any would-be contributors, but I just added this functionality in as 0.14-a0-3384-gc99d65b.

- Issue History
Date Modified Username Field Change
2014-03-20 01:22 MarvinPA New Issue
2014-03-20 02:31 sgrunt Note Added: 0025658
2014-03-20 02:31 sgrunt Assigned To => sgrunt
2014-03-20 02:31 sgrunt Status new => resolved
2014-03-20 02:31 sgrunt Resolution open => done
2014-03-21 10:35 MarvinPA Status resolved => closed
2014-03-21 10:35 MarvinPA Fixed in Branch => 0.14 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker