Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008270 [DCSS] Bug Report minor sometimes 2014-03-13 22:46 2014-03-16 00:18
Reporter tedric View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008270: Invis monsters are "sensed" in wrong tile
Description When an invisible monster is "sensed" (i.e. an outline shows up in their tile for a single turn), that outline is often in the wrong tile. Seems to be displacing the outline graphic to a random tile adjacent to the monster's position, making it appear as though the invisible monster is moving like a bat even when they are standing still from turn to turn. Appears to have started only in the last day or two.

CAO Webtiles 0.14-a0-3293-g65a9edf
username: tedric
Chrome, Ubuntu 13.10
Additional Information
Tags No tags attached.
Attached Files png file icon Dungeon Crawl Stone Soup 0.14 a0 3293 g65a9edf.png [^] (424,321 bytes) 2014-03-13 23:41

- Relationships

-  Notes
(0025594)
tedric (reporter)
2014-03-13 23:42

Added an image. The sky beast is diagonally adjacent to me (SE) -- you can see in the message log it just hit me. But as it vanishes, the outline appears one tile to the right.
(0025606)
roctavian (developer)
2014-03-14 22:40

This is intended behavior, and has been in the game for several versions.
(0025619)
gammafunk (administrator)
2014-03-15 03:31

This was actually intentionally implemented in versions past, but didn't work at all in tiles and not very often in console due to a recently fixed bug. However after some discussion it was agreed that the off-location invisible monster indicators are confusing in many situations and it's best that we only make accurate indicators for invisible monsters that fail the stealth check. So that change is in 0.14-a0-3317-geda97e8, thanks!
(0025624)
tedric (reporter)
2014-03-16 00:18

Thanks gammafunk!

- Issue History
Date Modified Username Field Change
2014-03-13 22:46 tedric New Issue
2014-03-13 23:41 tedric File Added: Dungeon Crawl Stone Soup 0.14 a0 3293 g65a9edf.png
2014-03-13 23:42 tedric Note Added: 0025594
2014-03-14 22:40 roctavian Note Added: 0025606
2014-03-15 03:31 gammafunk Note Added: 0025619
2014-03-15 03:31 gammafunk Status new => resolved
2014-03-15 03:31 gammafunk Fixed in Branch => 0.14 development branch
2014-03-15 03:31 gammafunk Resolution open => done
2014-03-15 03:31 gammafunk Assigned To => gammafunk
2014-03-16 00:18 tedric Note Added: 0025624
2014-03-16 00:18 tedric Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker