Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008254 [DCSS] Bug Report minor unable to reproduce 2014-03-10 07:12 2014-04-06 09:07
Reporter minmay View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008254: Gnoll wearing ring of protection from magic has umbra
Description A gnoll came into LOS wearing a "large opal ring." The gnoll had an umbra around it, consistent with the effect of ring of shadows. When I killed the gnoll, the umbra remained, and stayed there until I left the level, after which it disappeared. The ring turned out to be protection from magic.

I was unable to reproduce this bug in wizmode and unfortunately did not save my game at the appropriate time. The best I can do is the ttyrec (start at about turn 8600): http://dobrazupa.org/ttyrec/minmay/2014-03-10.05:22:40.ttyrec [^]

Note that on turn 0 I transferred from 0.14-a0-3157-gf92f90f to 0.14-a0-3168-gfdc5474.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Don-t-allow-non-unrand-rings-to-have-an-umbra.patch [^] (943 bytes) 2014-03-10 07:22 [Show Content]

- Relationships

-  Notes
(0025534)
pubby (reporter)
2014-03-10 07:24

I added a patch that might(?) fix this. I didn't try to reproduce and so there's a good chance the patch doesn't fix it.
(0025695)
wheals (administrator)
2014-03-25 16:18

OK, fixed. Sorry that I missed the patch.

- Issue History
Date Modified Username Field Change
2014-03-10 07:12 minmay New Issue
2014-03-10 07:22 pubby File Added: 0001-Don-t-allow-non-unrand-rings-to-have-an-umbra.patch
2014-03-10 07:24 pubby Note Added: 0025534
2014-03-25 16:18 wheals Note Added: 0025695
2014-03-25 16:18 wheals Status new => resolved
2014-03-25 16:18 wheals Fixed in Branch => 0.14 development branch
2014-03-25 16:18 wheals Resolution open => done
2014-03-25 16:18 wheals Assigned To => wheals
2014-04-06 09:07 minmay Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker