Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008246 [DCSS] Bug Report minor always 2014-03-07 23:01 2014-03-08 05:05
Reporter kurzedmetal View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008246: Potion of beneficial mutation is marked as useless_item for Vampire even when they are Alive
Description The title pretty much sum it up... Potions of benefical mutation are always marked as useless for Vampires even when they would have the full effect of the potion when Alive.
I'd bet this isn't the wanted behavior, at least not what I expected.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0025520)
neil (administrator)
2014-03-08 04:55

Fixed in trunk (0.14-a0-3140-gdeb40b5). They are now only marked as bad (and therefore useless) when you are below satiated.

However, there are still all the issues that arise from temporary uselessness: see 0002416 and 0005057.
(0025521)
neil (administrator)
2014-03-08 05:05

That affected both !mut and !benemut. I just pushed another change (0.14-a0-3142-g171a264) that makes !benemut never bad for vampires, since it always works at any satiation level.

- Issue History
Date Modified Username Field Change
2014-03-07 23:01 kurzedmetal New Issue
2014-03-08 04:55 neil Note Added: 0025520
2014-03-08 04:55 neil Status new => resolved
2014-03-08 04:55 neil Fixed in Branch => 0.14 development branch
2014-03-08 04:55 neil Resolution open => done
2014-03-08 04:55 neil Assigned To => neil
2014-03-08 05:05 neil Note Added: 0025521


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker