Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008220 [DCSS] Bug Report minor always 2014-02-27 07:50 2014-03-12 14:56
Reporter kurzedmetal View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008220: auto-explore+auto_sacrifice and auto_inscribe =p doesn't work
Description I was trying to make my config easier to play Nemelex, I decided to go auto_sacrifice = true and control which items to sacrifice by auto_inscribing =p to certain items.

When I tried my config, I found that that:
* with auto_sacrifice = true, auto-explore got stuck at the first item with =p found, answering the "really sacrifice?" question with "no" just made the question pop up again in a infinite loop, "yes" works as expected.
* with auto_sacrifice = before_explore, answering the "really sacrifice?" question with "no" didn't trigger the question again, but the auto-explore never ended, pressing any key stopped it and left the message log with a few hundred "You see here {item}." messages.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0025575)
Medar (developer)
2014-03-12 14:56

This should be fixed by: 0.14-a0-3260-g1751823 and 0.14-a0-3264-g73f3522

Not sure how useful the behavior is, but at least it shouldn't get stuck in a loop anymore. The affected inscriptions are =p, !p, !D and !*.

Because auto inscription is only made once you visit the square, with =p you will always get a prompt once. Using !D doesn't give a prompt.

- Issue History
Date Modified Username Field Change
2014-02-27 07:50 kurzedmetal New Issue
2014-03-12 14:20 Medar Issue Monitored: Medar
2014-03-12 14:56 Medar Note Added: 0025575
2014-03-12 14:56 Medar Status new => resolved
2014-03-12 14:56 Medar Fixed in Branch => 0.14 development branch
2014-03-12 14:56 Medar Resolution open => done
2014-03-12 14:56 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker