Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008213 [DCSS] Bug Report trivial always 2014-02-26 08:07 2014-03-04 00:59
Reporter Arrhythmia View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008213: Horn of Geryon has misleading description
Description The text says, paraphrased, that legends say a mortal must blow the horn to gain entry to hell. Obviously untrue these days, and when has a legend ever been untrue in a fantasy game?
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Remove-horn-of-Geryon.patch [^] (12,906 bytes) 2014-02-26 20:49 [Show Content]
? file icon 0001-Modify-Horn-of-Geryon-description.patch [^] (1,045 bytes) 2014-02-26 21:35 [Show Content]

- Relationships

-  Notes
(0025422)
Arrhythmia (reporter)
2014-02-26 09:23

Suggested fixes:

Remove the offending line

Replace the offending line with something accurate

Remove the horn of geryon
(0025428)
RBrandon (reporter)
2014-02-26 20:50
edited on: 2014-02-26 20:57

This patch removes the horn completely, but several on ##crawl-dev suggested this might not be the overall best course of action.

Edit: by removing the horn completely I mean the horn item. Geryon's flavour and description still reference the horn.

(0025429)
RBrandon (reporter)
2014-02-26 21:36

The second patch is much more conservative and only changes the item description. Should make a good fix while it is decided what (if anything) is to be done with the Horn.
(0025440)
gammafunk (administrator)
2014-03-04 00:59

Thanks OatmealLover and RBrandon for bringing attention to this. I've reworked the horn into an xp-charged evocable in 0.14-a0-2885-ge2f36c2. Further work could be done to make it more interesting, within reason (since it's always generated). Patches always welcome for consideration on that front!

- Issue History
Date Modified Username Field Change
2014-02-26 08:07 Arrhythmia New Issue
2014-02-26 09:23 Arrhythmia Note Added: 0025422
2014-02-26 20:49 RBrandon File Added: 0001-Remove-horn-of-Geryon.patch
2014-02-26 20:50 RBrandon Note Added: 0025428
2014-02-26 20:57 RBrandon Note Edited: 0025428
2014-02-26 21:07 wheals Issue Monitored: wheals
2014-02-26 21:35 RBrandon File Added: 0001-Modify-Horn-of-Geryon-description.patch
2014-02-26 21:36 RBrandon Note Added: 0025429
2014-02-27 06:24 gammafunk Status new => assigned
2014-02-27 06:24 gammafunk Assigned To => gammafunk
2014-02-27 08:25 wheals Issue End Monitor: wheals
2014-02-27 08:25 wheals Issue Monitored: wheals
2014-03-04 00:59 gammafunk Note Added: 0025440
2014-03-04 00:59 gammafunk Status assigned => resolved
2014-03-04 00:59 gammafunk Fixed in Branch => 0.14 development branch
2014-03-04 00:59 gammafunk Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker