Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008190 [DCSS] Patches feature N/A 2014-02-21 23:31 2014-06-27 00:30
Reporter pubby View Status public  
Assigned To Reaver
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0008190: Smith/fire god
Description A god idea that I coded for fun and hope to have playtested. I'm not sure if it's good or not, but if not then we'll at least know what abilities don't work.

The patch contains more details.
Additional Information
Tags No tags attached.
Attached Files ? file icon smithgod3.patch [^] (98,954 bytes) 2014-02-23 21:44 [Show Content]
? file icon 0001-Remove-gold-cost-and-the-Cherufe-species-from-smithg.patch [^] (79,126 bytes) 2014-06-23 23:45 [Show Content]

- Relationships

-  Notes
(0025355)
dpeg (administrator)
2014-02-22 01:12

I am a sucker for new gods :)

The concept is interesting, although I am not sure this is the best place for discussion. Here are some comments, but not with very much thought (yet):

1. Does the god pre-identify Enchant Foo scrolls?
2. I think there should be an ability which uses Igni altars as forges (either once per altar or once altogether).
3. Continuing that, a god is able to tinker with artefacts: make or change them. If going there (could be interesting!), then it should be more interesting than a mere (re)artefactise power.
4. I wonder if the reforge ability should be passive: helps a lot with the interface; I'm not worried it trivialises the early game.
5. Flaming brand has some uses, but sounds a bit lackluster. What if we stess the hammer idea, and the weapon is turned into a war hammer? (Will also do against hydras.)
5. The reforge ability (whether passive or active) could be extended to metal armour of enemies.
6. I like the AC boost of worn metal body armour. I am not sure the boost should depend on the type of armour; might be more interesting to make it flat.

I've got more to say, but perhaps that's better suited to private mail or the forum.
(0025357)
pubby (reporter)
2014-02-22 04:38

Hi dpeg. Replies to your comments:

1. Yes

2. Yeah, that's a fine idea, although it impacts flavour more than gameplay. The ability would need to be one-time-use, as otherwise it would be annoying to backtrack constantly to the altar. Do you have an idea for an ability that would work for this?
 
3. I thought of two systems for this, both which I realized were impractical when trying to code. The first allowed artefacts to be enchanted and modified by the player, but unfortunately the artefact code wasn't written with this in mind and thus requires lots of work and lots of save compat to be consistent. The second involved creating artefacts, where you would choose an item, then choose 4 rings, and an artefact would be created with ~2 of the 4 ring properties (all 4 rings would be destroyed). The problems with this is that the ring effects don't map exactly to artefact properties, the interface is confusing, and that it strays a bit too far into crafting mechanics that I don't think crawl needs.

4. How would a passive reforge work? It is important that weapons that the player would want to use are not reforged into mundane hammers.

5. I don't think mace & flails should have a clear advantage with this god as that reduces variation.

6. Ash and Chei already boost your AC from any type of armour, and so I think that this god should be different.

---

Thanks for the comments and the help you provided a few days ago. I am interested in what else you have to say, and discussing through either email or a forum thread will work. I'll probably create a forum thread on the weekend after I've played a few more games with this god.
(0025384)
neil (administrator)
2014-02-23 22:21

Now in the smithgod experimental branch on CSZO, along with 0008092.
(0025655)
raskol (reporter)
2014-03-18 19:20

Pressing ! on the artefactize menu results in a crash that doesn't recover well.

The aa ability respects "allow_self_target" meaning you can't use it on yourself if you have the option set to "no." Presumably it should be self-targetable the way wand of teleport is.
(0026628)
DracheReborn (reporter)
2014-06-23 23:48

New design of smithgod based on this:
https://crawl.develz.org/wiki/doku.php?id=dcss:brainstorm:god:propose:equipment [^]

This initial patch rolls back some of pubby's code that probably won't be needed any more. Nothing too exciting at the moment.
(0026632)
DracheReborn (reporter)
2014-06-24 02:20

As requested by reaverb, I'll make a new issue with separate patches
(0026636)
Reaver (developer)
2014-06-27 00:30

Since Drachereborn has created a new issue (0008736) and the other patch has long been pushed, resolving.

- Issue History
Date Modified Username Field Change
2014-02-21 23:31 pubby New Issue
2014-02-21 23:31 pubby File Added: smithgod.patch
2014-02-21 23:41 wheals Issue Monitored: wheals
2014-02-22 01:12 dpeg Note Added: 0025355
2014-02-22 04:38 pubby Note Added: 0025357
2014-02-23 03:31 pubby File Added: smithgod2.patch
2014-02-23 21:44 pubby File Added: smithgod3.patch
2014-02-23 22:21 neil Note Added: 0025384
2014-02-23 22:22 neil Status new => confirmed
2014-02-23 22:22 neil File Deleted: smithgod.patch
2014-02-23 22:22 neil File Deleted: smithgod2.patch
2014-03-18 19:20 raskol Note Added: 0025655
2014-06-23 23:45 DracheReborn File Added: 0001-Remove-gold-cost-and-the-Cherufe-species-from-smithg.patch
2014-06-23 23:45 DracheReborn Issue Monitored: DracheReborn
2014-06-23 23:48 DracheReborn Note Added: 0026628
2014-06-24 02:20 DracheReborn Note Added: 0026632
2014-06-27 00:30 Reaver Note Added: 0026636
2014-06-27 00:30 Reaver Status confirmed => resolved
2014-06-27 00:30 Reaver Fixed in Branch => 0.15 development branch
2014-06-27 00:30 Reaver Resolution open => done
2014-06-27 00:30 Reaver Assigned To => Reaver


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker