Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008186 [DCSS] Patches feature N/A 2014-02-21 17:19 2014-03-06 07:28
Reporter Sage View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008186: Make books auto-ID on walkover.
Description Saves a bit of hassle when you are near burdened or have no extra room in your inventory.
Additional Information
Tags No tags attached.
Attached Files ? file icon autoid-books.patch [^] (873 bytes) 2014-02-21 17:19 [Show Content]
? file icon book-id.patch [^] (3,167 bytes) 2014-02-22 11:17 [Show Content]
? file icon book-id-update.patch [^] (3,637 bytes) 2014-02-22 12:44 [Show Content]

- Relationships

-  Notes
(0025360)
Sage (reporter)
2014-02-22 11:29

The new patch makes it so that when you identify a book, you identify all books of that type. There's a bug though: when you identify one manual, you identify all manuals. Working on fixing that.
(0025362)
Sage (reporter)
2014-02-22 12:45

Auto-id was disabled for manuals. So the patch now makes spellbooks identify like staves, and manuals identify like they did before.
(0025365)
dpeg (administrator)
2014-02-22 14:32

Sage: So you have to pick up your first copy of Transfigurations (say), and all further ones are identified by walk-over? That sounds good to me.
(0025366)
Sage (reporter)
2014-02-22 14:51

No. When you identify :transfig, all other copies of :transfig are displayed in their identified form, like with enhancer staves. elliptic mentioned that it would be strange to rely either on xv or i to interact with a book depending on your burden status, and that made some sense to me. If that is not preferred, then I think walk-over identify for all spellbooks would be better than combining the two, since it would save some annoyance for the first spellbook of all types you see, and because if you can walk over it, odds are good that you can pick it up (dropping a piece of fruit if necessary).
(0025367)
dpeg (administrator)
2014-02-22 15:05

The position of the devteam might have changed, but last time I discussed this I thought we agreed that you shouldn't be able to deduce a book's content from afar. If this is still concensus then it seems that walkover-only would be the best interface.
(0025374)
elliptic (developer)
2014-02-23 04:53

dpeg: I can only speak for myself of course, but I see a difference between having all books identified at sight and having just those books that you have seen before identified at sight. In the first case, you always know from a distance whether you want a book, whereas in the second case there are still 40ish book types to identify by picking up as well as randart books.

I think the first case is more what has been discussed (and rejected) previously, whereas the second case seems good to me (mainly because it is more consistent with how identification works with other groups of items, e.g. staves).

- Issue History
Date Modified Username Field Change
2014-02-21 17:19 Sage New Issue
2014-02-21 17:19 Sage File Added: autoid-books.patch
2014-02-22 11:17 Sage File Added: book-id.patch
2014-02-22 11:29 Sage Note Added: 0025360
2014-02-22 12:44 Sage File Added: book-id-update.patch
2014-02-22 12:45 Sage Note Added: 0025362
2014-02-22 14:32 dpeg Note Added: 0025365
2014-02-22 14:51 Sage Note Added: 0025366
2014-02-22 15:05 dpeg Note Added: 0025367
2014-02-23 04:53 elliptic Note Added: 0025374
2014-02-24 12:43 MarvinPA Status new => resolved
2014-02-24 12:43 MarvinPA Fixed in Branch => 0.14 development branch
2014-02-24 12:43 MarvinPA Resolution open => done
2014-02-24 12:43 MarvinPA Assigned To => MarvinPA
2014-03-06 07:28 Sage Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker