Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008166 [DCSS] Patches feature N/A 2014-02-17 02:19 2014-02-24 18:23
Reporter wheals View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008166: Remove jellyfish, lemures, agate snails, and deep dwarf berserkers; make ufetubi explode
Description Crawl has lots of unnecessary monsters. I'm removing a few.
Additional Information
Tags No tags attached.
Attached Files ? file icon monsters.patch [^] (50,186 bytes) 2014-02-17 02:35 [Show Content]
? file icon monstersfixed.patch [^] (50,198 bytes) 2014-02-17 02:45 [Show Content]
? file icon spiny.patch [^] (15,841 bytes) 2014-02-23 19:08 [Show Content]

- Relationships

-  Notes
(0025336)
MarvinPA (developer)
2014-02-18 04:48
edited on: 2014-02-18 04:51

Pushed lemure and jellyfish removal. I don't have much of a problem with DD berserkers, since they can at least do something unlike most of the other removed DD monsters (but I wouldn't miss them). I haven't looked at the ufetubus thing yet.

Agate snail removal also sounds fine, not sure if the glyph move is necessary ('I' only has two monsters and no unique, although personally I've moved I to Y in my config, but bleh glyph bikeshedding). If the glyph move does happen then get_mon_shape() needs some changes to handle snails being 'w', for those all-important body part labels and whatever else monster shape is used for.

(0025345)
wheals (administrator)
2014-02-20 19:10
edited on: 2014-02-23 19:08

Added a patch to remove spiny worms.

e: and actually added it

(0025403)
wheals (administrator)
2014-02-24 18:23

Closing this now; 3/4 removals are in and I'm not really sure I thought out exploding ufetubi at all.

- Issue History
Date Modified Username Field Change
2014-02-17 02:19 wheals New Issue
2014-02-17 02:19 wheals File Added: monsters.patch
2014-02-17 02:35 chris File Deleted: monsters.patch
2014-02-17 02:35 wheals File Added: monsters.patch
2014-02-17 02:40 MarvinPA Issue Monitored: MarvinPA
2014-02-17 02:45 wheals File Added: monstersfixed.patch
2014-02-18 04:48 MarvinPA Note Added: 0025336
2014-02-18 04:50 MarvinPA Note Edited: 0025336
2014-02-18 04:51 MarvinPA Note Edited: 0025336
2014-02-20 19:10 wheals Note Added: 0025345
2014-02-23 19:08 wheals File Added: spiny.patch
2014-02-23 19:08 wheals Note Edited: 0025345
2014-02-24 18:23 wheals Note Added: 0025403
2014-02-24 18:23 wheals Status new => closed
2014-02-24 18:23 wheals Resolution open => done
2014-02-24 18:23 wheals Fixed in Branch => 0.14 development branch
2014-02-26 00:09 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker