Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008148 [DCSS] Patches major sometimes 2014-02-13 04:45 2014-02-25 06:00
Reporter wheals View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008148: Djinn
Description Removes Djinn.

Djinn have several problems. The greatest of them all is probably their use of several different "gimmicks," including EP, contam for hunger, hellfire resistance, and weird flying behaviour. Due to the first two they had lots and lots of special cases, and it was also incredibly hard to balance them for both the beginning and the endgame, especially for spellbook starts -- it took 6 months for there to be an online win with DjAE even though they had a good air apt. Removing hunger forced them into weird special cases with their contamination, which just set them apart from other races since crawl is simply no ready for food removal.

There doesn't seem to be much support for keeping Djinn in either among players or developers. You'll be able to finish games in progress.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Remove-djinn.patch [^] (71,759 bytes) 2014-02-13 04:47 [Show Content]
? file icon djinnwhitespace.patch [^] (71,733 bytes) 2014-02-13 06:36 [Show Content]

- Relationships

-  Notes
(0025413)
wheals (administrator)
2014-02-25 05:59

Pushed, thanks!

- Issue History
Date Modified Username Field Change
2014-02-13 04:45 wheals New Issue
2014-02-13 04:47 chris Issue Monitored: chris
2014-02-13 04:47 wheals File Added: 0001-Remove-djinn.patch
2014-02-13 06:36 wheals File Added: djinnwhitespace.patch
2014-02-25 05:59 wheals Status new => assigned
2014-02-25 05:59 wheals Assigned To => wheals
2014-02-25 05:59 wheals Note Added: 0025413
2014-02-25 05:59 wheals Status assigned => resolved
2014-02-25 05:59 wheals Fixed in Branch => 0.14 development branch
2014-02-25 05:59 wheals Resolution open => done
2014-02-25 06:00 wheals Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker