Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008120 [DCSS] Bug Report crash have not tried 2014-02-09 00:16 2014-03-09 16:09
Reporter johnnyzero View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008120: segfault in siren_song [no target]
Description While fighting a siren alongside a mercenary ally, Crawl crashed with a segfault in the siren_song(monster*) function. Looking at the crash log it seems as though the siren did not have a target for the spell. My guess would be that siren tried to sing at my mercenary instead of my character.

Relevant crash dump and save:
http://dobrazupa.org/morgue/johnnyzero/crash-johnnyzero-20140208-225441.txt [^]
https://dobrazupa.org/saves/johnnyzero-crawl-git-ac10382eb9-140208-2314.tar.bz2 [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0025237)
neil (administrator)
2014-02-09 15:40

Fixed in trunk (0.14-a0-2503-g52462b1), thanks! The problem was actually that there weren't enough available deep water tiles for the drowned souls to spawn.

- Issue History
Date Modified Username Field Change
2014-02-09 00:16 johnnyzero New Issue
2014-02-09 15:40 neil Note Added: 0025237
2014-02-09 15:40 neil Status new => resolved
2014-02-09 15:40 neil Fixed in Branch => 0.14 development branch
2014-02-09 15:40 neil Resolution open => done
2014-02-09 15:40 neil Assigned To => neil
2014-03-09 16:09 johnnyzero Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker