Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008108 [DCSS] Bug Report minor have not tried 2014-02-06 16:40 2014-07-02 23:14
Reporter Aracanid View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008108: Water tiles display crystal wall rather than water type
Description Cannot remember what path i took but an area of deep water with shallow water paths was drawn with apparently the crystal wall tile in the middle with water edgeing(?). Makes this area difficult to navigate. Continues to draw certain areas of water incorrectly as I explore.
Additional Information
Tags No tags attached.
Attached Files png file icon crawltileswatererror.PNG [^] (474,672 bytes) 2014-02-06 16:40
png file icon water error.PNG [^] (491,907 bytes) 2014-02-06 16:45
? file icon yevgeni.cs [^] (383,989 bytes) 2014-06-19 15:56
png file icon 2tHVHle.png [^] (555,582 bytes) 2014-06-19 15:57

- Relationships
duplicate of 0006150assignedmumra Wrong tiles in crystal cavern 

-  Notes
(0026557)
Kvaak (reporter)
2014-06-19 15:58

Still in as of 0.15-a0-1573-g47cdaed. Attached a save file and a screenshot. The tile in the middle is an altar of Makhleb, the three tiles in the corners are fountains and the tile at the end of the hallway is a staircase down.
(0026558)
neil (administrator)
2014-06-19 16:16

The tile for that square is being set by the layout, because it was originally a crystal wall. Then the vault placed and overwrote the wall, but didn't change the tile.

Usually the layouts in question use LROCKTILE to avoid that (and RTILE would be fine too), but this layout wants to replace those with green crystal so has to set TILE instead.

dat/dlua/layout/theme.lua
(0026671)
neil (administrator)
2014-07-02 23:14

Turns out I was wrong: the problem was that the vault was placing *before* the layout. Layout placement avoids overwriting vault-masked features, but did overwrite the colour, tile, and properties of the cells. Fixed in trunk (0.15-a0-1853-ge872541).

- Issue History
Date Modified Username Field Change
2014-02-06 16:40 Aracanid New Issue
2014-02-06 16:40 Aracanid File Added: crawltileswatererror.PNG
2014-02-06 16:45 Aracanid Issue Monitored: Aracanid
2014-02-06 16:45 Aracanid File Added: water error.PNG
2014-06-19 15:56 Kvaak File Added: yevgeni.cs
2014-06-19 15:57 Kvaak File Added: 2tHVHle.png
2014-06-19 15:58 Kvaak Note Added: 0026557
2014-06-19 16:16 neil Note Added: 0026558
2014-07-02 22:59 neil Relationship added duplicate of 0006150
2014-07-02 23:14 neil Note Added: 0026671
2014-07-02 23:14 neil Status new => resolved
2014-07-02 23:14 neil Fixed in Branch => 0.15 development branch
2014-07-02 23:14 neil Resolution open => done
2014-07-02 23:14 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker