Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008103 [DCSS] Patches feature N/A 2014-02-05 17:06 2014-02-25 01:24
Reporter wheals View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008103: Rod of Bolts
Description This patch replaces rod of destruction {lightning bolt, fireball, iron shot} with the rod of bolts {venom, draining, lightning, fire, cold}. If having five spells is deemed to make the rod too good, I'd prefer to have lightning removed since it's the closest to an existing rod (rod of lightning), though personally I think it's still very different.
Additional Information
Tags No tags attached.
Attached Files ? file icon randbolts2.patch [^] (12,455 bytes) 2014-02-09 02:39 [Show Content]

- Relationships

-  Notes
(0025212)
Galefury (updater)
2014-02-05 18:53

Maybe take it one step further and make it cast a random bolt? Possibly excluding lightning because of bouncing. You could even add in inacc in that case, it just checks EV instead of a resistance. This would simplify the interface, because the rod would have just a single spell. Also it would be a bit more interesting IMO.

It would require a bit of god handling though.
(0025217)
wheals (administrator)
2014-02-07 03:57
edited on: 2014-02-09 02:40

I uploaded a patch that makes it have a spell that releases venom, draining, fire, cold, or quicksilver. There's no god handling at present; possibly it should just be marked as evil and fire-causing and leave it at that.

e: randbolts2.patch: lowered rod evoke cost to 5, lowered quicksilver bolt damage, marked it as potentially fire-starting and evil

(0025411)
wheals (administrator)
2014-02-25 01:23

Pushed.

- Issue History
Date Modified Username Field Change
2014-02-05 17:06 wheals New Issue
2014-02-05 17:06 wheals File Added: 0001-Replace-plain-rod-of-destruction-with-rod-of-bolts.patch
2014-02-05 18:53 Galefury Note Added: 0025212
2014-02-07 03:55 wheals File Added: randombolts.patch
2014-02-07 03:57 wheals Note Added: 0025217
2014-02-09 02:39 wheals File Added: randbolts2.patch
2014-02-09 02:40 wheals Note Edited: 0025217
2014-02-09 13:09 chris File Deleted: randombolts.patch
2014-02-09 13:10 chris File Deleted: 0001-Replace-plain-rod-of-destruction-with-rod-of-bolts.patch
2014-02-10 14:49 chris Issue Monitored: chris
2014-02-25 01:23 wheals Note Added: 0025411
2014-02-25 01:23 wheals Status new => resolved
2014-02-25 01:23 wheals Fixed in Branch => 0.14 development branch
2014-02-25 01:23 wheals Resolution open => done
2014-02-25 01:23 wheals Assigned To => wheals
2014-02-25 01:24 wheals Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker