Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008097 [DCSS] Implementables major have not tried 2014-02-03 19:36 2014-04-27 05:24
Reporter sgrunt View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008097: Tiles needed for new enemies
Description The following new enemies need tiles:
----
drowned soul

A cold and hollow apparition of the drowned dead, chained by some lingering
attachment to the depths in which it perished. They clamour around the living,
sharing the last moments of their watery fate with whatever their pale form
touches.
----
salamander mystic

A member of the salamander's scholarly caste, possessed of lesser size and
strength, but wise in the ways of magic. Through hermetic rites, they can
channel the fire within them to empower their allies, hurl blasts of lava or,
by fusing their arts with those of their naga brethren, ignite even a single
drop of poison within the veins of an enemy.
----
salamander firebrand

The rarest of the salamander castes, possessed of fearsome agility and
unparallelled martial prowess. Their mastery of fire is woven into every strike
of their weapons, filling the air around their opponent with sweltering flames.
So hot does their blood run that even outside their native terrain, few can
escape their pursuit.
----

The following enemies have bad temporary tiles and could use permanent tiles:
----
worldbinder

A cloud of thick fog, with faint, feeble claws constantly reaching
out and grasping futily before being pulled back in by the fog.
Worldbinders tie themselves to specific locations and absorb part of
the weaker natives banished to the Abyss, enabling them to summon
echoes from one of many locations against percieved threats.
----
naga ritualist

An esoteric mystic draped in talismans. Their sect venerate poison as a sacred
gift and means of spiritual purification, and their affinity for it is even
stronger than the rest of their kin. By invoking secret rites they can render
any venom more potent and spread its touch upon all those around them.
----
grand avatar

An avatar of battle and bloodshed, capable of mimicking sufficiently damaging
melee attacks and conjurations from its creator and their allies.
----

Also desirable: a better set of tiles for the new demonspawn enemies (monstrous/gelid/infernal/putrid/torturous demonspawn and their classes: blood saint, chaos champion, warmonger, corrupter, black sun); the classes are probably more important than the base tiles.

See also 0008087 where new uniques need tiles.
Additional Information
Tags No tags attached.
Attached Files png file icon naga ritualist.png [^] (1,111 bytes) 2014-02-04 00:03


png file icon salamanders.png [^] (5,684 bytes) 2014-02-04 09:56


png file icon binder.png [^] (5,967 bytes) 2014-02-09 22:35


png file icon worldbinder.png [^] (6,027 bytes) 2014-02-09 22:42


png file icon salamanders2.png [^] (5,928 bytes) 2014-02-09 23:01


png file icon demonspawns.png [^] (17,816 bytes) 2014-02-24 05:40


png file icon guardians.png [^] (4,213 bytes) 2014-03-04 01:54


png file icon mostly.formicids.png [^] (11,811 bytes) 2014-03-08 00:58


png file icon viper.spell.avatar.png [^] (13,718 bytes) 2014-03-13 04:22

- Relationships
related to 0008087resolved Need tiles for Asterion and Natasha 
related to 0008194resolvedsgrunt War gargoyle + (Doll) Hauberk tiles 

-  Notes
(0025196)
coolio (reporter)
2014-02-04 00:04

Here's a naga ritualist. It's nothing special but it's roughly on par with the existing nagas.
(0025202)
roctavian (developer)
2014-02-04 07:39

On it for the salamander tiles; also re-doing the original Salamander tile.
(0025205)
roctavian (developer)
2014-02-04 09:57

L-R: Salamander, firebrand, and mystic.
(0025210)
sgrunt (administrator)
2014-02-04 18:19

I've added the salamander tiles, thanks!
(0025226)
ontoclasm (developer)
2014-02-08 22:04

I pushed a (bad) tile for drowned souls.
(0025257)
roctavian (developer)
2014-02-09 22:43

Worldbinder tile. Sorry, I only meant the second one.
(0025258)
roctavian (developer)
2014-02-09 23:03

Additionally, I tweaked the salamander tiles after spectating a couple games. A few color things, some tiny pose adjustments, and hats to spice up the mystics.
(0025259)
sgrunt (administrator)
2014-02-09 23:35

I've polished up the ritualist tile a bit and added it in; thanks coolio! I'll need to know how you want to be credited in CREDITS.TXT.

I've also added the worldbinder tile and tweaked salamander tiles; thanks again roctavian!

That leaves grand avatars and possible work on the demonspawn enemies.

Come to think of it, mana vipers could use a better tile too.
(0025338)
Claws (developer)
2014-02-18 06:08

There were also some monster revamps deserving of re-tiling recently; metal gargoyles into war gargoyles, crystal golems into crystal guardians. Both are dramatically different enough that a new tile would be good, especially as the former is indistinct in its spawning location and doesn't have any way to display its weapon.

As a reference, the descriptions for the two:

"When standard gargoyles are created, they're animated from intimidating, carved stone figures and serve as immensely armoured and resilient, if structurally fragile, guardians for their positions. Rarely, gargoyles are prepared for their animation, smithed from impressively lightweight metal into solid winged statues with nasty speed, strength, and weaponized breath. These gargoyles ruthlessly crush intruders."

"An intricate animated statue made of heavily ensorcelled, tough crystal. Though these magical defense structures are delicately sculpted to the point of lacking structural integrity and have little capability for dodging, they are immune to most forms of magic, and are magically charged to toss great bolts of fire and cold that are reflected by any surface."
(0025391)
roctavian (developer)
2014-02-24 05:43

Demonspawn tiles are up.
L-R:
Warmonger, blood saint, black sun, corrupter, chaos champion
Normal, monstrous, gelid, infernal, putrid, torturous
(0025394)
sgrunt (administrator)
2014-02-24 06:06

The demonspawn tiles are in; thanks!

Reading back through this thread (and taking 0008194 into consideration), this leaves: grand avatars, mana vipers, and crystal guardians.
(0025399)
coolio (reporter)
2014-02-24 14:51

sgrunt, I'm already credited in credits.txt, under my real name.
(0025418)
sgrunt (administrator)
2014-02-26 04:01

As I just noticed, we also need a tile for guardian golems:

A large construct, designed to protect. It can take the blows dealt to others upon itself, though it is prone to becoming unstable and overheating after heavy punishment.
(0025444)
roctavian (developer)
2014-03-04 01:58

Just upped tiles for crystal guardian, guardian golem. Spellforged servitor will be on the way, but I just moved and I won't have proper internet until Thursday at the earliest.

Looking at these a few days after I made them -- I kind of think the crystal guardian has a potbelly, and if anyone wants to alter the coloration/add a new facet of crystal/something to change that, I'd be obliged. Or I'll do it sometime next week.
(0025445)
sgrunt (administrator)
2014-03-04 02:28

As I noted during the absence, we could also use tiles for the following enemies: (molten) gargoyles that can show weapons, formicids (and formicid venom mages), and (less importantly) vine stalkers (who only appear as dummy monsters).

This makes the list: grand avatar (though the current tile is better than the original tile), mana viper, gargoyle, molten gargoyle, formicid, formicid venom mage, vine stalker.
(0025499)
sgrunt (administrator)
2014-03-07 01:26

One more for the list: octopode crushers.
(0025516)
roctavian (developer)
2014-03-08 01:00

VS (though we know it should be Vi), Fo, FoVM, CG, and Wb. Removed Crystal Guardian potbelly, improved the appearance of the Worldbinder tile, the fog of which resembled a kernel of popcorn in my first draft.
(0025517)
sgrunt (administrator)
2014-03-08 03:38

Landed the new tiles; thanks!

Current needs: grand avatar, mana viper, (molten) gargoyle, spellforged servitor (alluded to in a previous note, but I didn't personally mention them), octopode crusher.
(0025556)
sgrunt (administrator)
2014-03-11 01:02

Bloax has come forward with some (molten) gargoyle tiles; hooray!

Current needs: grand avatar, mana viper, spellforged servitor, octopode crusher.
(0025566)
sgrunt (administrator)
2014-03-11 22:09

I borrowed the old viper tile to transform into a mana viper tile, which looks much better than what we had before (and so is in).

Current needs: grand avatar, spellforged servitor, octopode crusher.
(0025567)
sgrunt (administrator)
2014-03-11 22:34

...and Bloax has provided us with an octopode crusher, leaving us needing a grand avatar and a spellforged servitor.
(0025582)
roctavian (developer)
2014-03-13 04:25

Mana viper, spellforged servitor, and a messy draft of grand avatar. I'm having trouble making a body that doesn't look terrible, I uploaded what I have in case someone else wants to make a go at it. I'll try to do something with it later, and maybe I'll come up with something satisfying.
(0025583)
sgrunt (administrator)
2014-03-13 05:03

Hooray! The first two of those are in; I'll let either you or someone else (ontoclasm?) figure out what to do with the grand avatar, and then I can close this.
(0025761)
roctavian (developer)
2014-03-31 21:01

I just noticed that (at least in a0-2820) several of the demonspawn class overlays are off by a pixel:

Too far right: Chaos Champion, Corruptor

Too far left: Blood Saint

The other ones are fine.
(0025763)
sgrunt (administrator)
2014-03-31 22:00

I adjusted those tiles; thanks!
(0025778)
Reaver (developer)
2014-04-03 22:36

Closed because the Grand Avatar tile has gone in (5e01d95)

- Issue History
Date Modified Username Field Change
2014-02-03 19:36 sgrunt New Issue
2014-02-03 19:37 sgrunt Relationship added related to 0008087
2014-02-04 00:03 coolio File Added: naga ritualist.png
2014-02-04 00:04 coolio Note Added: 0025196
2014-02-04 07:39 roctavian Note Added: 0025202
2014-02-04 07:39 roctavian Note Added: 0025203
2014-02-04 07:39 roctavian Note Deleted: 0025203
2014-02-04 09:56 roctavian File Added: salamanders.png
2014-02-04 09:57 roctavian Note Added: 0025205
2014-02-04 18:19 sgrunt Note Added: 0025210
2014-02-08 22:04 ontoclasm Note Added: 0025226
2014-02-09 22:35 roctavian File Added: binder.png
2014-02-09 22:42 roctavian File Added: worldbinder.png
2014-02-09 22:43 roctavian Note Added: 0025257
2014-02-09 23:01 roctavian File Added: salamanders2.png
2014-02-09 23:03 roctavian Note Added: 0025258
2014-02-09 23:35 sgrunt Note Added: 0025259
2014-02-18 06:08 Claws Note Added: 0025338
2014-02-24 05:40 roctavian File Added: demonspawns.png
2014-02-24 05:43 roctavian Note Added: 0025391
2014-02-24 05:43 roctavian Note Added: 0025392
2014-02-24 05:43 roctavian Note Deleted: 0025392
2014-02-24 05:56 sgrunt Relationship added related to 0008194
2014-02-24 06:06 sgrunt Note Added: 0025394
2014-02-24 14:51 coolio Note Added: 0025399
2014-02-26 04:01 sgrunt Note Added: 0025418
2014-03-04 01:54 roctavian File Added: guardians.png
2014-03-04 01:58 roctavian Note Added: 0025444
2014-03-04 02:28 sgrunt Note Added: 0025445
2014-03-07 01:26 sgrunt Note Added: 0025499
2014-03-08 00:58 roctavian File Added: mostly.formicids.png
2014-03-08 01:00 roctavian Note Added: 0025516
2014-03-08 03:38 sgrunt Note Added: 0025517
2014-03-11 01:02 sgrunt Note Added: 0025556
2014-03-11 22:09 sgrunt Note Added: 0025566
2014-03-11 22:34 sgrunt Note Added: 0025567
2014-03-13 04:22 roctavian File Added: viper.spell.avatar.png
2014-03-13 04:25 roctavian Note Added: 0025582
2014-03-13 05:03 sgrunt Note Added: 0025583
2014-03-31 21:01 roctavian Note Added: 0025761
2014-03-31 22:00 sgrunt Note Added: 0025763
2014-04-03 22:36 Reaver Note Added: 0025778
2014-04-03 22:36 Reaver Status new => resolved
2014-04-03 22:36 Reaver Resolution open => done
2014-04-03 22:36 Reaver Assigned To => Reaver
2014-04-27 05:24 sgrunt Assigned To Reaver =>
2014-04-27 05:24 sgrunt Status resolved => closed
2014-04-27 05:24 sgrunt Fixed in Branch => 0.14 stable branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker