Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008088 [DCSS] Patches feature N/A 2014-02-02 05:25 2014-02-03 22:07
Reporter wheals View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008088: Some unrand changes.
Description Some notes on the patch:

Finisher: I thought that very rarely giving it to Sigmund would be a funny thing to do while not making him actually that much more lethal than usual (mostly because when he has it, you know).
Zhor: Compared to a +2 robe of resistance, it had rF- rC+ and +2 AC. Most people would not wear a ring that had that even if they had a spare slot. This might at least make it more interesting, since a triple resistance isn't possible on a randart.
Leech: It was often worse than a +0 vamp demon blade (since the ego item can be enchanted and doesn't lower stats). It's a bit more unique now.
Sniper: It might overlap a little with the dark maul, but I think it's interesting.
Snakebite: Venom is one of the worse brands on a dwhip but curare is amazing. I tried to strike a balance.
Colonel's sabre: A lot of people really missed the uniqueness.
Singing Sword: It was generally pretty poor. A scimitar or demon blade would be a bit out of flavour, so I upgraded it to bastard.
Gong: Blame minqmay.
Additional Information
Tags No tags attached.
Attached Files ? file icon unrands2.patch [^] (19,983 bytes) 2014-02-02 06:00 [Show Content]

- Relationships

-  Notes
(0025165)
wheals (administrator)
2014-02-02 06:00

Removed the Finisher change and buffed Sniper a bit.
(0025194)
MarvinPA (developer)
2014-02-03 22:05

Pushed, minus the Captain's cutlass redefine and plus a few additional tweaks.

- Issue History
Date Modified Username Field Change
2014-02-02 05:25 wheals New Issue
2014-02-02 05:27 wheals File Added: 0001-Make-some-unrands-more-interesting-bring-back-two.patch
2014-02-02 05:57 MarvinPA Issue Monitored: MarvinPA
2014-02-02 06:00 wheals File Added: unrands2.patch
2014-02-02 06:00 wheals Note Added: 0025165
2014-02-02 14:02 chris File Deleted: 0001-Make-some-unrands-more-interesting-bring-back-two.patch
2014-02-03 22:05 MarvinPA Note Added: 0025194
2014-02-03 22:05 MarvinPA Status new => resolved
2014-02-03 22:05 MarvinPA Fixed in Branch => 0.14 development branch
2014-02-03 22:05 MarvinPA Resolution open => done
2014-02-03 22:05 MarvinPA Assigned To => MarvinPA
2014-02-03 22:05 MarvinPA Issue End Monitor: MarvinPA
2014-02-03 22:07 wheals Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker