Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008080 [DCSS] Patches minor have not tried 2014-01-31 07:30 2015-01-22 01:38
Reporter Siegurt View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008080: Patch to add current attack delay to description of currently wielded weapon
Description This patch adds a 'current delay' to the description of the currently wielded weapon when examined in the inventory.

It uses a two-digit precision floating point number (to better explain to the user why they don't always get the exact same attack delay when the rounding is between two whole AUTs)

It does add some code to scale the attack delay of weapons up by a factor of 10 so this additional level of precision can be displayed, which may or may not be desirable from a maintenance standpoint (In particular since the formula for calculating delay is under construction, it may make integrating this patch undesirable,or at least inconvienent at the current time)
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Adding-current-delay-to-description-of-current-wield.patch [^] (7,432 bytes) 2014-01-31 07:30 [Show Content]

- Relationships

-  Notes
(0025155)
chris (updater)
2014-01-31 07:40

Current attack delay is mostly already visible in the HUD, and I don't like cluttering up the description with more numbers.
What i'd suggest instead of this is adding a line when min delay has been reached, possibly a short form of that line could also be printed in attack speed hints like when pressing `@`.
(0027883)
wheals (administrator)
2014-11-23 01:12

Implemented chris's suggestion in http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=f2aae5a3abdf. [^]
(0028332)
Siegurt (reporter)
2015-01-22 01:38

Different implementation used, issue mostly resolved

- Issue History
Date Modified Username Field Change
2014-01-31 07:30 Siegurt New Issue
2014-01-31 07:30 Siegurt File Added: 0001-Adding-current-delay-to-description-of-current-wield.patch
2014-01-31 07:40 chris Note Added: 0025155
2014-11-23 01:12 wheals Note Added: 0027883
2014-11-23 01:12 wheals Status new => resolved
2014-11-23 01:12 wheals Fixed in Branch => 0.16 development branch
2014-11-23 01:12 wheals Resolution open => done
2014-11-23 01:12 wheals Assigned To => wheals
2015-01-22 01:38 Siegurt Note Added: 0028332
2015-01-22 01:38 Siegurt Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker