Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008075 [DCSS] Bug Report minor have not tried 2014-01-30 01:39 2014-09-16 21:53
Reporter silentsnack View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008075: Drowned wights leave no items
Description From a pack of Wights I encountered on an enchanter, the ones I confused into deep water left nothing but if I killed them by other means they left weapons and armor as usual.

Other monsters left corpses as usual on drowning. Did not get a good opportunity to test other item-carrying creatures.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0025172)
neil (administrator)
2014-02-02 18:24

Were you playing a race that can swim?
(0025180)
silentsnack (reporter)
2014-02-02 21:15

Yes, guess I should have mentioned. OpEn.
(0025181)
neil (administrator)
2014-02-02 22:24

Hm. Looks like this is specific to wights and other non-drownable but non-swimming monsters. If they fall into water, they aren't killed, but permanently submerge (with a message in debugging mode).
(0025182)
silentsnack (reporter)
2014-02-02 22:28

I guess that explains why they also seemed to give no experience.
(0027286)
wheals (administrator)
2014-09-16 21:53

Davy Jones' locker is gone, rip (2d02254e2a3221)

- Issue History
Date Modified Username Field Change
2014-01-30 01:39 silentsnack New Issue
2014-02-02 18:24 neil Note Added: 0025172
2014-02-02 21:15 silentsnack Note Added: 0025180
2014-02-02 22:24 neil Note Added: 0025181
2014-02-02 22:28 silentsnack Note Added: 0025182
2014-09-16 21:53 wheals Note Added: 0027286
2014-09-16 21:53 wheals Status new => resolved
2014-09-16 21:53 wheals Fixed in Branch => 0.15 prerelease branch
2014-09-16 21:53 wheals Resolution open => done
2014-09-16 21:53 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker