Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008069 [DCSS] Patches minor have not tried 2014-01-29 00:06 2014-02-02 18:56
Reporter Siegurt View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008069: Patch to put >100% spell failure in spell description
Description It was pointed out that it'd be nice to have *some* indication of how far from 100% a spell was when you were when training spell schools.

This patch puts the spell failure percent in the spell's description when over 100% as "Guaranteed Fail:" and the uncapped "greater-than-100%" spell failure figure, it doesn't change the "I" menu, or anything outside the description.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Adding-Over-100-percent-fails-to-spell-descriptions.patch [^] (2,684 bytes) 2014-01-29 00:06 [Show Content]

- Relationships

-  Notes
(0025121)
Siegurt (reporter)
2014-01-29 00:08

See https://crawl.develz.org/tavern/viewtopic.php?f=8&t=10738 [^] for the forum topic in which this suggestion arose
(0025122)
dpeg (administrator)
2014-01-29 00:11

Thanks! I suggest to apply this: the number is relevant (because we already give success percentages), and it is not force-fed to people (as it's not a number which is crucial all the time).
(0025174)
neil (administrator)
2014-02-02 18:48

In trunk (0.14-a0-2391-gd8f276c), thanks!
(0025176)
Siegurt (reporter)
2014-02-02 18:56

Nice!

- Issue History
Date Modified Username Field Change
2014-01-29 00:06 Siegurt New Issue
2014-01-29 00:06 Siegurt File Added: 0001-Adding-Over-100-percent-fails-to-spell-descriptions.patch
2014-01-29 00:08 Siegurt Note Added: 0025121
2014-01-29 00:11 dpeg Note Added: 0025122
2014-02-02 18:48 neil Note Added: 0025174
2014-02-02 18:48 neil Status new => resolved
2014-02-02 18:48 neil Fixed in Branch => 0.14 development branch
2014-02-02 18:48 neil Resolution open => done
2014-02-02 18:48 neil Assigned To => neil
2014-02-02 18:56 Siegurt Note Added: 0025176
2014-02-02 18:56 Siegurt Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker