Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008049 [DCSS] Patches feature N/A 2014-01-25 10:18 2015-11-02 00:43
Reporter gammafunk View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008049: Octopode Crusher: An octopode warrior that likes throwing weight around.
Description From the commit:

This monster is meant to be roughly on par with the shoals:5 merfolk, so it has
the same HD/HP profile as an impaler. In addition to the spell Corona, it has
one new spell and one new ability.

New spell: (tentatively named) Water Harpoon. Throws a conjured harpoon of
water projectile at the victim dealing the same damage as stone arrow and then
yanking the victim to a random square adjacent to the caster. The landing site
is always habitable for the victim, who must not currently be adjacent to the
caster nor be constricted.

New ability: Throw. A 2 in 5 chance to hurl a victim that's currently being
constricted by the crusher for undodgable, AC-checking damage, preferably "into"
(i.e. adjacent to) a solid feature for 50% increased damage. The base throw
damage is currently HD * 3. The landing site is always habitable for the
victim and the feature site must be visible to the monster if the damage
increase is to apply. If no landing site adjacent to a solid feature can be
found, any habitable landing site in LOS is used, but then only the base damage
applies.

Water harpoon and throw could also be given to more powerful monsters, as the
crusher itself is probably too weak for Depths. The water harpoon spell could
be made into a nice player spell; the throwing ability is not quite so simple to
give to players due to targeting issues, but if we chose a random landing site
and made e.g. size restrictions, it might be usable as either an ability or
spell.

Additional Notes:
The name of the monster and the spell are certainly up for discussion. Some UC titles like Grappler, Brawler, and Wrestler could be used in place of Crusher. Mauler was another suggestion. The range of water harpoon is 6, same as icicle, but currently the throw range is full LOS radius. Possibly we should put some more restrictions as to when something can be "pulled" (e.g. monsters in webs). Right now the restrictions for throw/harpoon are basically habitability and not being constricted (except by the monster, in the case of throw).
Additional Information
Tags No tags attached.
Attached Files ? file icon op_crusher_gca92d1a38.patch [^] (20,726 bytes) 2014-01-25 10:18 [Show Content]

- Relationships

-  Notes
(0025250)
gammafunk (administrator)
2014-02-09 19:53

I don't think this was in any danger of getting merged prematurely, but just a couple of notes:

1) It can't go in as-is since I have to make water harpoon directly use beam mechanics instead of going through zapping(). I learned that this is a player-only function; I'm getting messages of "Really fire through your centaur?" when a hostile crusher tries to harpoon me through a centaur I summon with shadow creatures.

2) I discussed the placement of this monster, mostly with tenofswords, and the thinking is that while a monster with both harpoon and throw would possibly get annoying in large numbers, it should be nice in pop_water_depths, probably replacing MONS_OCTOPODE and adding a MONS_NO_MONSTER there.
(0025488)
gammafunk (administrator)
2014-03-06 08:41

There's a branch for op-crusher now that will probably get merged soon.
(0029728)
gammafunk (administrator)
2015-11-02 00:43

Opc were merged this version.

- Issue History
Date Modified Username Field Change
2014-01-25 10:18 gammafunk New Issue
2014-01-25 10:18 gammafunk File Added: op_crusher_gca92d1a38.patch
2014-02-09 19:53 gammafunk Note Added: 0025250
2014-03-06 08:41 gammafunk Note Added: 0025488
2014-03-06 08:41 gammafunk Status new => resolved
2014-03-06 08:41 gammafunk Fixed in Branch => 0.14 development branch
2014-03-06 08:41 gammafunk Resolution open => done
2014-03-06 08:41 gammafunk Assigned To => gammafunk
2015-11-02 00:43 gammafunk Note Added: 0029728
2015-11-02 00:43 gammafunk Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker