Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008033 [DCSS] Bug Report tweak have not tried 2014-01-23 09:12 2014-01-24 13:47
Reporter Grandiloquent Gentleman View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008033: Jump ability says nothing about the inability to jump on invalid targets
Description I tried to jump to some stairs but got the message "There is nothing there, so you fail to move!"
This should be clearly stated in the description.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0025059)
gammafunk (administrator)
2014-01-24 02:18

The description doesn't mention this, but the player is warned when they attempt such an attack. The description could be modified to mention this:

"Be advised that if you try to jump-attack something unseen and it turns out nothing was there, or if something unseen blocks your path, you will fail to move."

It seems a bit awkward to list all these exceptions when the interface takes care of the warnings and messages.

Allowing a jump-attack attempt on a square with no visible monster was regarded as preferable to not allowing it according to many players I spoke with, however we could just require a visible monster as a target.
(0025062)
MarvinPA (developer)
2014-01-24 13:47

Adjusted the desc to specify that it targets a monster.

- Issue History
Date Modified Username Field Change
2014-01-23 09:12 Grandiloquent Gentleman New Issue
2014-01-24 02:18 gammafunk Note Added: 0025059
2014-01-24 13:47 MarvinPA Note Added: 0025062
2014-01-24 13:47 MarvinPA Status new => resolved
2014-01-24 13:47 MarvinPA Fixed in Branch => 0.14 development branch
2014-01-24 13:47 MarvinPA Resolution open => done
2014-01-24 13:47 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker