Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008026 [DCSS] Bug Report crash always 2014-01-22 07:54 2014-01-26 06:06
Reporter Arrhythmia View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008026: Casting bolt of fire w/ Dith crashes game
Description When I cast bolt of fire using wizmode as a HEFi in sprint who is at 200 piety via wizmode, the game crashes with "ASSERT(power > 0) in 'mon-cast.cc' at line 250 failed". Considering that it only happens on every other cast or so, I'm willing to bet it's tied to the shadow-mimic.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0025088)
sgrunt (administrator)
2014-01-26 06:06

Turns out this was a symptom of a much greater problem - shadow mimic's HD was always 1 when spellcasting unless the player's XL was 1, where its HD was 0 (causing the crash here).

0.14-a0-2099-g7c294fe fixes the relevant logic to give it half your XL as HD unless you're XL1, in which case it's HD1.

- Issue History
Date Modified Username Field Change
2014-01-22 07:54 Arrhythmia New Issue
2014-01-26 06:06 sgrunt Note Added: 0025088
2014-01-26 06:06 sgrunt Assigned To => sgrunt
2014-01-26 06:06 sgrunt Status new => resolved
2014-01-26 06:06 sgrunt Resolution open => done
2014-01-26 06:06 sgrunt Fixed in Branch => 0.14 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker