Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007967 [DCSS] Patches feature always 2014-01-09 23:04 2014-01-20 10:49
Reporter araganzar View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007967: Linkify URLs in webchat
Description This process takes messages destined for the chat server and runs them through a simple replace to create workable links. Other HTML such <span> will not be affected. Any valid http, https, or ftp link will work, as will www.example.com even without the http://. [^] Email addresses will also change to a mailto link.

This functionality will be configurable with a future patch.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Linkify-URLs-in-webchat.patch [^] (1,903 bytes) 2014-01-09 23:04 [Show Content]
? file icon 0001-Linkify-chat.patch [^] (9,361 bytes) 2014-01-10 21:34 [Show Content]
? file icon 0001-Linkify-chat-new-window.patch [^] (9,402 bytes) 2014-01-10 21:52 [Show Content]
? file icon 0001-Linkify-chat-with-scheme-control.patch [^] (9,461 bytes) 2014-01-10 22:37 [Show Content]
? file icon 0001-Linkify-chat-with-scheme-control-2.patch [^] (9,444 bytes) 2014-01-10 22:49 [Show Content]

- Relationships

-  Notes
(0024965)
araganzar (reporter)
2014-01-10 21:36

New patch posted. This uses a linkify.js that is MIT and GPL licensed. I did not modify license.txt because i was unsure of the procedure but I am happy to do so.

This version should be fairly bulletproof and will check for open quotes, parens, and other special characters that could break HTML.
(0024967)
araganzar (reporter)
2014-01-10 22:38

0001-Linkify-chat-with-scheme-control.patch allows only https, http, irc, and ftp to start links
(0024968)
araganzar (reporter)
2014-01-10 22:50

removed confusing messages from patch commits, new patch uploaded as 0001-Linkify-chat-with-scheme-control-2
(0025031)
Medar (developer)
2014-01-20 10:49

Thanks a lot. Linkifying is in: 0.14-a0-2036-gdc57c81

I ended up taking a bit different approach, so I didn't use your patch directly.

- Issue History
Date Modified Username Field Change
2014-01-09 23:04 araganzar New Issue
2014-01-09 23:04 araganzar File Added: 0001-Linkify-URLs-in-webchat.patch
2014-01-09 23:18 neil Description Updated
2014-01-10 21:34 araganzar File Added: 0001-Linkify-chat.patch
2014-01-10 21:36 araganzar Note Added: 0024965
2014-01-10 21:52 araganzar File Added: 0001-Linkify-chat-new-window.patch
2014-01-10 22:37 araganzar File Added: 0001-Linkify-chat-with-scheme-control.patch
2014-01-10 22:38 araganzar Note Added: 0024967
2014-01-10 22:49 araganzar File Added: 0001-Linkify-chat-with-scheme-control-2.patch
2014-01-10 22:50 araganzar Note Added: 0024968
2014-01-20 10:49 Medar Note Added: 0025031
2014-01-20 10:49 Medar Status new => resolved
2014-01-20 10:49 Medar Fixed in Branch => 0.14 development branch
2014-01-20 10:49 Medar Resolution open => done
2014-01-20 10:49 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker