Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007958 [DCSS] Bug Report minor always 2014-01-05 16:31 2014-01-08 02:33
Reporter Lorkhan View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007958: Lava Orcs when "fired up" can access books?
Description According to the description of the Lava Orc species, when they are fired up, items like scrolls and books are not accessible. When it happens(temperature at its fullest, enemies getting scorched around me) scrolls can't be read but magic books can be accessed(to pick a spell for memorization).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024929)
ion_frigate (reporter)
2014-01-05 17:54
edited on: 2014-01-05 17:54

Can't find the commit but I seem to recall that this is intentional, the consensus being that there's no real tactical value in memorizing spells in battle, so there's no reason to forbid it for LO when hot.

Also, from a flavour standpoint, scrolls can be destroyed by fire but spellbooks can't, so perhaps spellbooks have some sort of fire-resistant magical construction.

(0024937)
MarvinPA (developer)
2014-01-07 03:22

Pretty sure it's intentional yeah, being hot shouldn't prevent you from browsing books since that's purely an interface thing (and blocking memorisation/forgetting spells doesn't matter either way).
(0024939)
Medar (developer)
2014-01-07 16:33

Like the report says, documentation still mentions books as being inaccessible.

I don't have time to look through it right now, so I'm reopening this instead.
(0024940)
MarvinPA (developer)
2014-01-08 02:33
edited on: 2014-01-08 02:34

Ah I misread. Fixed the wiki manual entry for them, as far as I can tell everywhere else (A and A! screens mainly) only talks about scrolls.


- Issue History
Date Modified Username Field Change
2014-01-05 16:31 Lorkhan New Issue
2014-01-05 17:54 ion_frigate Note Added: 0024929
2014-01-05 17:54 ion_frigate Note Edited: 0024929
2014-01-05 17:54 ion_frigate Note Edited: 0024929
2014-01-07 03:22 MarvinPA Note Added: 0024937
2014-01-07 03:22 MarvinPA Status new => resolved
2014-01-07 03:22 MarvinPA Fixed in Branch => 0.14 development branch
2014-01-07 03:22 MarvinPA Resolution open => no change required
2014-01-07 03:22 MarvinPA Assigned To => MarvinPA
2014-01-07 16:33 Medar Note Added: 0024939
2014-01-07 16:33 Medar Status resolved => new
2014-01-07 16:33 Medar Resolution no change required => reopened
2014-01-08 02:33 MarvinPA Note Added: 0024940
2014-01-08 02:33 MarvinPA Status new => resolved
2014-01-08 02:33 MarvinPA Resolution reopened => done
2014-01-08 02:34 MarvinPA Note Edited: 0024940


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker