Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007929 [DCSS] Bug Report minor have not tried 2013-12-28 18:59 2015-05-05 01:54
Reporter petzl View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007929: A character can initially start game wearing shield and wielding 2-handed weapon
Description A character can initially start game wearing shield and wielding 2-handed weapon, in violation of the rule that wearing a shield makes 2-handed weapons unwieldable and wielding a 2-handed weapon makes a shield unwearable.

I entered game as a Djinni Wanderer with a wielded quarterstaff and worn buckler; this should not be possible since a quarterstaff is a 2-handed weapon.

I noticed this when I unwielded the quarterstaff and (unsuccessfully) tried to re-wield.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0007282resolvedKiloByte Wanderers do not always check that starting items can be [w/W]ed together. 
has duplicate 0008144closedMedar Wanderers can start with quarterstaff and buckler equipped 

-  Notes
(0024862)
chris (updater)
2013-12-28 19:06

Note also 0.13-a0-2809-g04436d7

http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=04436d723803 [^]

Prevent wanderers from wielding 2h + shield.
(0024863)
neil (administrator)
2013-12-28 19:30
edited on: 2013-12-28 19:31

Looks like can_wear_armour doesn't actually check about 2H weapons, so only half of pubby's fix works: if you get the shield first the quarterstaff won't be wielded, but if you get the quarterstaff first the shield will still be created pre-equipped.

(0025653)
wheals (administrator)
2014-03-18 18:21

The case where the shield is given second should be fixed.
(0029008)
Le_Nerd (reporter)
2015-05-04 21:42

Had this happen again, shortbow+buckler on a mummy wanderer. http://crawl.develz.org/morgues/git/Svalbardcaretaker/morgue-Svalbardcaretaker-20150504-151511.txt [^]
(0029012)
wheals (administrator)
2015-05-05 00:43

Were you actually equipping both at the game start? IMO it's OK if you have to choose between using the bow and the shield, but if they were both equipped that's obviously a bug.
(0029013)
Le_Nerd (reporter)
2015-05-05 01:54

Pretty sure both were equipped from the start. By the time I had realized what happened I had already unwielded and was unable to re-equip, leading to an early demise.

- Issue History
Date Modified Username Field Change
2013-12-28 18:59 petzl New Issue
2013-12-28 19:06 chris Note Added: 0024862
2013-12-28 19:30 neil Note Added: 0024863
2013-12-28 19:31 neil Note Edited: 0024863
2013-12-28 19:31 neil Relationship added duplicate of 0007282
2014-02-12 16:09 Medar Relationship added has duplicate 0008144
2014-03-18 18:21 wheals Note Added: 0025653
2014-03-18 18:21 wheals Status new => resolved
2014-03-18 18:21 wheals Fixed in Branch => 0.14 development branch
2014-03-18 18:21 wheals Resolution open => done
2014-03-18 18:21 wheals Assigned To => wheals
2015-05-04 21:42 Le_Nerd Note Added: 0029008
2015-05-05 00:43 wheals Note Added: 0029012
2015-05-05 01:54 Le_Nerd Note Added: 0029013


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker