Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007912 [DCSS] Bug Report minor have not tried 2013-12-25 21:32 2013-12-25 22:13
Reporter magicpoints View Status public  
Assigned To galehar
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007912: Shift+Key does not work in skill menu for skills beyond the 26th available
Description This mostly affects potions or cards of experience, as they allow training any skill. For skills whose selection key is a number, pressing Shift+Number will not select only that skill. Shift+Letter works for skills selected by letter.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024840)
galehar (administrator)
2013-12-25 22:13

This isn't a bug, just a limitation. Shift letter is just a shortcut, if you want to select only your 27th skill, you can just manually disable the others.

It's not trivial to fix, because shift-number is actually a different character which depends on keyboard layout. Unless you try shift-numpad, but this has other issues and I don't know how to add them as menu hotkeys. It would probably have the same problem as "running" with numpad (works only with or without numlock depending on console/tiles/webtiles interface and OS or terminal).

It's also extremely rare to have more than 26 trainable skills. I'm pretty sure it never happens unless the player is specifically going for it for some reason (you have to carry a weapon of each type and know a spell of each school).

In the end, I doubt it's worth worrying about and certainly not keeping a bug open for it. If somebody wants to write a patch, fine, but there's a million things more interesting to invest time in.

- Issue History
Date Modified Username Field Change
2013-12-25 21:32 magicpoints New Issue
2013-12-25 22:13 galehar Note Added: 0024840
2013-12-25 22:13 galehar Status new => resolved
2013-12-25 22:13 galehar Fixed in Branch => 0.14 development branch
2013-12-25 22:13 galehar Resolution open => done
2013-12-25 22:13 galehar Assigned To => galehar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker