Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007906 [DCSS] Bug Report tweak always 2013-12-23 15:05 2013-12-23 16:11
Reporter Somebody View Status public  
Assigned To galehar
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007906: Cheibriados should extend duration of player's Transformations and Charms, for the sake of us all
Description There seems to be a wonderful idea in the works to make R/DMsl spells'duration based on number of missiles they act on, and form spells permanent, but this design seems to be in a *very* early stage, while in the meantime, sanity of anyone who wants to keep, for example, Lich-form or RMSL always active while worshipping Cheibriados is in greater danger than ever.

Chei already slows down player's metabolism and monster generation in the Abyss and on the Orb run, so this is an extension of already-implemented principle. It seems very counter-intuitive for the God whose motto is "Take it Easy!" to make your fauvorite playstyle a bigger hassle than before.

P.S. Since I was encouraged to write the patch for this change on ##crawl-dev, which unfortunately I cannot do, I am writing it here, so it can be marked as implementable.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024824)
KiloByte (manager)
2013-12-23 15:45

How is this a "bug"?
(0024825)
galehar (administrator)
2013-12-23 15:51

There's a reason not everybody has rights to create implementables, we don't take feature requests on Mantis.
(0024826)
Somebody (reporter)
2013-12-23 16:11
edited on: 2013-12-23 18:06

Okay, sorry about posting it here. I will take it to the dcss:brainstorm:god:cheibriados on the wiki.


- Issue History
Date Modified Username Field Change
2013-12-23 15:05 Somebody New Issue
2013-12-23 15:45 KiloByte Note Added: 0024824
2013-12-23 15:51 galehar Note Added: 0024825
2013-12-23 15:51 galehar Status new => resolved
2013-12-23 15:51 galehar Fixed in Branch => 0.14 development branch
2013-12-23 15:51 galehar Resolution open => done
2013-12-23 15:51 galehar Assigned To => galehar
2013-12-23 16:11 Somebody Note Added: 0024826
2013-12-23 18:06 Somebody Note Edited: 0024826


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker