Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007904 [DCSS] Patches feature N/A 2013-12-23 00:59 2014-03-06 07:35
Reporter Sage View Status public  
Assigned To Medar
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0007904: Use yes_or_no for attacks which will cause penance instead of yesno, and make the warning more explicit.
Description Mostly to prevent Oka worshippers from hitting enslaved eels without sufficient warning.
Additional Information
Tags No tags attached.
Attached Files ? file icon prompt-on-penance-attack.patch [^] (10,561 bytes) 2013-12-23 00:59 [Show Content]
? file icon prompt-on-penance-attack-fedhas-included.patch [^] (9,642 bytes) 2013-12-25 18:03 [Show Content]
? file icon penance-attack-3.patch [^] (10,488 bytes) 2014-01-30 09:57 [Show Content]

- Relationships

-  Notes
(0024838)
Sage (reporter)
2013-12-25 18:04

Added a case with Fedhas I overlooked, and fixed a minor formatting issue.
(0025148)
Sage (reporter)
2014-01-30 10:12

Update added.

Fireball under Fedhas sometimes does not display "would place you under penance" if it would affect friendly mushrooms and friendly not-mushrooms. It seems that Fireball uses the version of stop_attack_prompt that starts with a monster* instead of a targetter& parameter, so the problem is likely in beam.cc (possibly that Fireball stops looking for bad attacks after the first one).
(0025149)
Medar (developer)
2014-01-30 10:14

Applied: 0.14-a0-2348-g140b27c

Thanks a lot.

- Issue History
Date Modified Username Field Change
2013-12-23 00:59 Sage New Issue
2013-12-23 00:59 Sage File Added: prompt-on-penance-attack.patch
2013-12-25 18:03 Sage File Added: prompt-on-penance-attack-fedhas-included.patch
2013-12-25 18:04 Sage Note Added: 0024838
2014-01-30 09:57 Sage File Added: penance-attack-3.patch
2014-01-30 10:12 Sage Note Added: 0025148
2014-01-30 10:14 Medar Note Added: 0025149
2014-01-30 10:14 Medar Status new => resolved
2014-01-30 10:14 Medar Fixed in Branch => 0.14 development branch
2014-01-30 10:14 Medar Resolution open => done
2014-01-30 10:14 Medar Assigned To => Medar
2014-03-06 07:35 Sage Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker