Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007897 [DCSS] Patches feature N/A 2013-12-21 05:22 2014-03-06 07:38
Reporter Sage View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0007897: Vine stalker species.
Description Parasitic vines. Powerful bite which leeches mana and applies antimagic, bites every melee attack, regen III, spirit shield, +1 MP. -3 HP, can't restore HP with potions or wands (Gods and regeneration in general work).
Additional Information
Tags No tags attached.
Attached Files ? file icon vine_stalkers.patch [^] (57,880 bytes) 2013-12-21 05:22 [Show Content]
png file icon vine_stalker_f.png [^] (800 bytes) 2013-12-21 05:22


png file icon vine_stalker_m.png [^] (778 bytes) 2013-12-21 05:23


png file icon stalker.png [^] (587 bytes) 2013-12-21 18:31


png file icon stalker_fixed.png [^] (552 bytes) 2013-12-21 22:23


? file icon vine_stalkers_squashed.patch [^] (29,986 bytes) 2013-12-25 06:16 [Show Content]
? file icon vine-stalker-update.patch [^] (4,399 bytes) 2013-12-31 00:53 [Show Content]
? file icon vine-stalker-complete.patch [^] (34,390 bytes) 2013-12-31 00:53 [Show Content]
? file icon vine-stalker-update-2.patch [^] (6,204 bytes) 2013-12-31 02:58 [Show Content]
? file icon plane-stalker.patch [^] (1,218 bytes) 2013-12-31 03:54 [Show Content]
? file icon mutation-name.patch [^] (741 bytes) 2013-12-31 05:11 [Show Content]
? file icon vine-stalker-update-3.patch [^] (5,377 bytes) 2013-12-31 06:49 [Show Content]
? file icon suppress-invig.patch [^] (1,438 bytes) 2013-12-31 22:43 [Show Content]
? file icon vine-stalker-update-4.patch [^] (3,319 bytes) 2014-01-01 13:14 [Show Content]
? file icon vine-stalker-update-5.patch [^] (5,667 bytes) 2014-01-05 01:57 [Show Content]
? file icon vine-stalker-update-6.patch [^] (2,413 bytes) 2014-01-10 05:35 [Show Content]
? file icon vs.patch [^] (55,690 bytes) 2014-01-25 08:44 [Show Content]

- Relationships

-  Notes
(0024799)
Bloax (reporter)
2013-12-21 18:32

How about this doll?
(0024800)
dck (reporter)
2013-12-21 19:13

Knew I could count on ya bloax, gj.
(0024801)
Bloax (reporter)
2013-12-21 19:55
edited on: 2013-12-21 20:12

Say, what if the bite damage is always somewhat equally relevant?
https://docs.google.com/spreadsheet/pub?key=0AsKF0KRvqPwidGlVaXZpMzNIclF5V2pSWW5kTUNnSXc&output=html [^]

"(mutlevel*3) + (mutlevel*3)*(xl/27)*(1+(str/30))" Seems to do the trick, and provides quite a bunch of knobs to turn instead of a single one.

(0024802)
Bloax (reporter)
2013-12-21 22:23

Fixed the damn border.
(0024803)
dck (reporter)
2013-12-21 22:50

Initially factoring in str was not so much a reasoned decision but more of a leftover from the original aux bite formula. It doesn't add much more than breakpoints.
In the current revision it is (mutlevel*3) + XL*2/3 which by and large seems be providing a good damage curve and allowing the bite to remain relevant (as the core mechanic to the race it is).
Numbers can (and likely will) be tweaked later down the road based on feedback on the strength of the bite, but as we stand right now it's good for testing purposes, it seems.
(0024804)
Bloax (reporter)
2013-12-22 00:46

The reason I added strength in there is because I like strength affecting something beyond your weapon's damage, since it's in such an abstract form that it really ought to do so.
(0024835)
Sage (reporter)
2013-12-25 06:39

Added the squashed patch; sorry about not doing it before.
(0024878)
neil (administrator)
2013-12-30 18:37

This is an experimental branch on CSZO now: T)runk -> X)perimental -> V)ine Stalker (or choose it from the webtiles lobby).
(0024883)
johlstei (reporter)
2013-12-30 22:59

Copy pasting from tavern - sorry in advance for ugly code formatting.

- case WAND_HASTING: // each 17.9%, group unknown each 26.3%
         case WAND_HEAL_WOUNDS:
+ if (you.mutation[MUT_NO_DEVICE_HEAL])
+ w = 0; break;
+ case WAND_HASTING: // each 17.9%, group unknown each 26.3%
             w = 25; break;

Is this a bug? It looks like you don't assign w if you are not a vine stalker. Did you mean to put braces around the "w = 0; break;"? Sorry if this isn't the place for this, it just happened to catch my eye and its just subtle enough that I don't think it would be easily noticed.
(0024885)
Sage (reporter)
2013-12-31 00:58

Another couple files. vine-stalker-update has a few patches for issues I've been informed of: Now /HW should not be gray for VS when not identified; VS shouldn't get mana from summons or firewood; and the antimagic bite message has been tweaked for non-spellcasting creatures. vine-stalker-complete has everything from "Vine stalkers added" to the new patches, and has unneeded whitespaces removed--I used checkwhite incorrectly in the old patches. Sorry about that.
(0024886)
neil (administrator)
2013-12-31 02:55

Applied the second patch in vinestalker branch and updated CSZO.
(0024887)
neil (administrator)
2013-12-31 03:38

Applied update-2.
(0024888)
Sage (reporter)
2013-12-31 06:50

Another nerf. Postpone regen III until xl8, halve manavamp across the board, and a couple fixes for my errors.
(0024892)
neil (administrator)
2013-12-31 18:24

Applied patches up to and including -update-3. Also merged in trunk.
(0024925)
neil (administrator)
2014-01-05 02:10

Applied update-5
(0024959)
neil (administrator)
2014-01-10 07:14

Applied update-6
(0025078)
Sage (reporter)
2014-01-25 08:48

Added vs.patch--I (hopefully) resolved conflicts, so it should be ready for trunk.
(0025096)
neil (administrator)
2014-01-26 17:54

In trunk (0.14-a0-2115-g202e82eb), thanks!

- Issue History
Date Modified Username Field Change
2013-12-21 05:22 Sage New Issue
2013-12-21 05:22 Sage File Added: vine_stalkers.patch
2013-12-21 05:22 Sage File Added: vine_stalker_f.png
2013-12-21 05:22 Sage Issue Monitored: Sage
2013-12-21 05:22 Sage Issue End Monitor: Sage
2013-12-21 05:23 Sage File Added: vine_stalker_m.png
2013-12-21 18:31 Bloax File Added: stalker.png
2013-12-21 18:32 Bloax Note Added: 0024799
2013-12-21 19:13 dck Note Added: 0024800
2013-12-21 19:55 Bloax Note Added: 0024801
2013-12-21 20:12 Bloax Note Edited: 0024801
2013-12-21 22:23 Bloax File Added: stalker_fixed.png
2013-12-21 22:23 Bloax Note Added: 0024802
2013-12-21 22:50 dck Note Added: 0024803
2013-12-22 00:46 Bloax Note Added: 0024804
2013-12-25 06:16 Sage File Added: vine_stalkers_squashed.patch
2013-12-25 06:39 Sage Note Added: 0024835
2013-12-30 18:37 neil Note Added: 0024878
2013-12-30 18:37 neil Status new => confirmed
2013-12-30 22:59 johlstei Note Added: 0024883
2013-12-31 00:53 Sage File Added: vine-stalker-update.patch
2013-12-31 00:53 Sage File Added: vine-stalker-complete.patch
2013-12-31 00:58 Sage Note Added: 0024885
2013-12-31 02:55 neil Note Added: 0024886
2013-12-31 02:58 Sage File Added: vine-stalker-update-2.patch
2013-12-31 03:38 neil Note Added: 0024887
2013-12-31 03:54 Sage File Added: plane-stalker.patch
2013-12-31 05:11 Sage File Added: mutation-name.patch
2013-12-31 06:49 Sage File Added: vine-stalker-update-3.patch
2013-12-31 06:50 Sage Note Added: 0024888
2013-12-31 18:24 neil Note Added: 0024892
2013-12-31 22:43 Sage File Added: suppress-invig.patch
2014-01-01 13:14 Sage File Added: vine-stalker-update-4.patch
2014-01-05 01:57 Sage File Added: vine-stalker-update-5.patch
2014-01-05 02:10 neil Note Added: 0024925
2014-01-10 05:35 Sage File Added: vine-stalker-update-6.patch
2014-01-10 07:14 neil Note Added: 0024959
2014-01-25 08:44 Sage File Added: vs.patch
2014-01-25 08:48 Sage Note Added: 0025078
2014-01-26 17:54 neil Note Added: 0025096
2014-01-26 17:54 neil Status confirmed => resolved
2014-01-26 17:54 neil Fixed in Branch => 0.14 development branch
2014-01-26 17:54 neil Resolution open => done
2014-01-26 17:54 neil Assigned To => neil
2014-03-06 07:38 Sage Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker