Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007867 [DCSS] Bug Report trivial always 2013-12-15 17:49 2013-12-17 17:00
Reporter battaile View Status public  
Assigned To Medar
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0007867: color tags visible in 'drop' and 'multi-pickup' menus
Description Where you get the "select all with …" dialog, the select-all key is displayed with the enclosing "<w></w>" tag visible. e.g. "select all with <w>!</w>"
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024737)
SamB (developer)
2013-12-15 19:37

This is not really HTML, but Crawl's own tags. (Still a bug, of course, but probably not the same kind of bug as if it were actually HTML.)

Also, [in the future] please give the whole version number, and note that the "g" is not part of the commit hash. (I tried to run "git describe g6a017cb" with no success, was convinced you must have extra commits locally, and was about to send you a complicated "git" command to run that would show me what was up before I noticed the "g"...)
(0024738)
battaile (reporter)
2013-12-15 20:08

Ok, might want to change the instructions next to the version from "e.g. 0.5.2 or 0.6.0-a1-2964-g6b485cb or 6b485cb", since that seems to imply you can submit the last 8 characters as a valid entry.
(0024740)
Medar (developer)
2013-12-15 22:24

Fixed in 0.14-a0-1505-g02256d3. Thanks for the report.
(0024748)
battaile (reporter)
2013-12-17 04:24

gracias
(0024752)
neil (administrator)
2013-12-17 17:00

battaile: the commit hash itself is fine, just leave off the g or you'll confuse SamB :P It wouldn't be so bad if git used a letter that wasn't adjacent to the hex digits....

- Issue History
Date Modified Username Field Change
2013-12-15 17:49 battaile New Issue
2013-12-15 19:37 SamB Note Added: 0024737
2013-12-15 19:37 SamB Product Version g6a017cb => 0.14-a0-1500-g6a017cb
2013-12-15 19:37 SamB Summary HTML tags visible in 'drop' and 'multi-pickup' menus => color tags visible in 'drop' and 'multi-pickup' menus
2013-12-15 20:08 battaile Note Added: 0024738
2013-12-15 22:24 Medar Note Added: 0024740
2013-12-15 22:24 Medar Status new => resolved
2013-12-15 22:24 Medar Fixed in Branch => 0.14 development branch
2013-12-15 22:24 Medar Resolution open => done
2013-12-15 22:24 Medar Assigned To => Medar
2013-12-17 04:24 battaile Note Added: 0024748
2013-12-17 04:24 battaile Status resolved => closed
2013-12-17 17:00 neil Note Added: 0024752


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker