Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007857 [DCSS] Patches feature have not tried 2013-12-13 00:00 2014-01-12 15:02
Reporter Cedor View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0007857: MR and Stealth stat bar
Description Here is the first implementation, more for comment purpose.

Position can be easily adjusted, and adjective revamp was purely arbitrary, so it can easily be reverted (or amended). To avoid some to duplicate even more code, I need to rewrite some util funcion, and once it'll be done, i'll push the 10 dot stealth bar. Precision, 10 dots will be too much for the column, so I should have to move the bar closer to the title. Another option is to write stealth outside of the multicolumn part (just before the @: part)
Additional Information
Tags No tags attached.
Attached Files ? file icon 0002-MR-stat-bar.patch [^] (1,695 bytes) 2013-12-19 01:11 [Show Content]
? file icon 0003-Stealth-bar.patch [^] (1,369 bytes) 2013-12-19 01:11 [Show Content]
? file icon 0001-Rewriting-of-_itosym(corrected).patch [^] (6,154 bytes) 2013-12-19 09:25 [Show Content]
? file icon 0003-Stealth-bar(10dots).patch [^] (1,752 bytes) 2013-12-19 10:47 [Show Content]
? file icon 0001-Rewriting-of-_itosym-v2.patch [^] (6,298 bytes) 2014-01-05 14:52 [Show Content]
? file icon 0002-MR-stat-bar-v2.patch [^] (1,703 bytes) 2014-01-05 14:52 [Show Content]
? file icon 0001-Rewriting-of-_itosym-v3.patch [^] (9,123 bytes) 2014-01-05 21:03 [Show Content]
? file icon 0002-MR-stat-bar-v3.patch [^] (1,919 bytes) 2014-01-05 22:04 [Show Content]

- Relationships

-  Notes
(0024721)
Cedor (reporter)
2013-12-13 00:20

fail on my commits... The second patch is the good one (the other can be deleted).
(0024771)
Cedor (reporter)
2013-12-19 01:15
edited on: 2013-12-19 09:38

ok, 3 patches version :
first a rewriting of a function, then the MR bar (5 levels, adjectives revamped), then the 5 dots Stealth bar (10 dots version coming)

(0024778)
Cedor (reporter)
2013-12-19 10:48

Corrected code cleaning patch, and 10 dots stealth bar.
(0024911)
MarvinPA (developer)
2014-01-03 14:58

The _itosym rewrite patch doesn't seem to work correctly, it breaks the spacing on % and doesn't display most resistances properly.
(0024928)
Cedor (reporter)
2014-01-05 14:56
edited on: 2014-01-05 15:13

ok, was my fault. second version corrected. After discussions it seems a great part of the % panel should be rewrited with strings stream instead of printf.

(0024931)
Cedor (reporter)
2014-01-05 21:03
edited on: 2014-01-05 21:05

last version : V3

removing of all the .c_str, the buf, and everything handled through strings.

(0024948)
MarvinPA (developer)
2014-01-09 09:57

Looks good, I'm not keen on having the @ breakpoints for MR be different to the % breakpoints though. I'm not really sure what a better set of breakpoints for both would look like though.
(0024949)
Cedor (reporter)
2014-01-09 10:37

I thought @ display use the magic_res_adjective() function, that's why I mirrored it with the breakpoints from my bar. And as I said, my breakpoints a arbitrary, so they can be reworked at will. Except the maximum because someone (dpeg?) said no monster spell can go over 200 spell power.

And if we want to have more than 5 level of MR, we should move the MR bar outside of the resist columns (like a did with the 10 dots stealth bar).
(0024977)
MarvinPA (developer)
2014-01-12 14:26
edited on: 2014-01-12 14:27

Pushed, thanks for the patches. Will leave this open for a bit in case we still want to add a stealth bar too (since presumably that needs a bit of discussion on details first if so).

Edit: actually I'll resolve this, opening a new issue for a stealth bar is probably easier to follow.

(0024978)
Cedor (reporter)
2014-01-12 15:02

I think so.

- Issue History
Date Modified Username Field Change
2013-12-13 00:00 Cedor New Issue
2013-12-13 00:00 Cedor File Added: 0001-MR-and-Stealth-stat-bar.patch
2013-12-13 00:20 Cedor File Added: 0002-MR-and-Stealth-stat-bar.patch
2013-12-13 00:20 Cedor Note Added: 0024721
2013-12-13 01:43 chris File Deleted: 0001-MR-and-Stealth-stat-bar.patch
2013-12-18 23:25 Cedor File Added: 0001-MR-and-Stealth-stat-bar.patch
2013-12-18 23:28 SamB File Deleted: 0002-MR-and-Stealth-stat-bar.patch
2013-12-19 00:48 Cedor File Added: 0001-Rewriting-of-_itosym.patch
2013-12-19 01:11 Cedor File Added: 0002-MR-stat-bar.patch
2013-12-19 01:11 Cedor File Added: 0003-Stealth-bar.patch
2013-12-19 01:15 Cedor Note Added: 0024771
2013-12-19 01:19 Cedor Note Edited: 0024771
2013-12-19 01:20 SamB File Deleted: 0001-MR-and-Stealth-stat-bar.patch
2013-12-19 09:25 Cedor File Added: 0001-Rewriting-of-_itosym(corrected).patch
2013-12-19 09:38 Cedor Note Edited: 0024771
2013-12-19 10:47 Cedor File Added: 0003-Stealth-bar(10dots).patch
2013-12-19 10:48 Cedor Note Added: 0024778
2013-12-20 00:25 SamB File Deleted: 0001-Rewriting-of-_itosym.patch
2013-12-30 00:39 MarvinPA Issue Monitored: MarvinPA
2014-01-03 14:58 MarvinPA Note Added: 0024911
2014-01-05 14:52 Cedor File Added: 0001-Rewriting-of-_itosym-v2.patch
2014-01-05 14:52 Cedor File Added: 0002-MR-stat-bar-v2.patch
2014-01-05 14:56 Cedor Note Added: 0024928
2014-01-05 15:13 Cedor Note Edited: 0024928
2014-01-05 21:03 Cedor File Added: 0001-Rewriting-of-_itosym-v3.patch
2014-01-05 21:03 Cedor Note Added: 0024931
2014-01-05 21:05 Cedor Note Edited: 0024931
2014-01-05 22:04 Cedor File Added: 0002-MR-stat-bar-v3.patch
2014-01-09 09:57 MarvinPA Note Added: 0024948
2014-01-09 10:37 Cedor Note Added: 0024949
2014-01-12 14:26 MarvinPA Note Added: 0024977
2014-01-12 14:27 MarvinPA Note Edited: 0024977
2014-01-12 14:27 MarvinPA Status new => resolved
2014-01-12 14:27 MarvinPA Fixed in Branch => 0.14 development branch
2014-01-12 14:27 MarvinPA Resolution open => done
2014-01-12 14:27 MarvinPA Assigned To => MarvinPA
2014-01-12 15:02 Cedor Note Added: 0024978
2014-01-12 15:02 Cedor Status resolved => closed
2014-02-02 03:18 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker