Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007837 [DCSS] Documentation text N/A 2013-12-09 08:33 2013-12-10 16:48
Reporter putridmelon View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007837: 'Targetting' consistently misspelled
Description The word 'targetting' is consistently misspelled throughout the documentation and in-game help. The correct spelling is 'targeting'. (This is so in all flavors of English, i.e. UK, US, Canada, Australia etc.)
Additional Information
Tags No tags attached.
Attached Files txt file icon patch.txt [^] (17,440 bytes) 2013-12-09 12:20 [Show Content]

- Relationships
duplicate of 0005268closedneil Targeting has ONE T. 

-  Notes
(0024648)
MarvinPA (developer)
2013-12-09 11:19
edited on: 2013-12-09 11:20

According to 0005268 it's correct in AU English (that or Linley just used "tt" incorrectly). But yeah it looks awful and wrong to me.

(0024649)
putridmelon (reporter)
2013-12-09 12:15

Sorry for reporting a duplicate. But the double T is wrong in AU as elsewhere, and the reason is already given in 0005268.

Like you said it looks awful; it's a silly-looking blemish on an otherwise excellent interface.

I can do a sed on the docs and/or code (which I've noticed also uses the double T) of course, but it does touch a lot of lines and I'm not sure if anyone is willing to accept a fairly large patch from a newcomer.

Also, there's one thing to be wary of: there's an option 'mlist_targetting'. Changing that will break existing option files that use it. Would be best to change it in the docs but ensure that the old (misspelled) option continues to be recognized by the code.
(0024650)
putridmelon (reporter)
2013-12-09 12:21

I uploaded a patch that fixes the docs except the 'mlist_targetting' option, as that would break existing option files. (See my comment in the duplicate.)
(0024657)
galehar (administrator)
2013-12-10 09:18

Do you have any source or reference about the spelling? Otherwise, I'm afraid it might be reverted again because "that's how Linley spelled it".
(0024660)
KiloByte (manager)
2013-12-10 14:21

This was researched before:
* the US speling is -t-
* UK allows both, with -tt- being historic, mostly supplanted with -t-
* AU uses nearly exclusively -tt-, with -t- apparently coming mostly from outside

I tried two AU spell checkers, one accepted both forms, one highlights -t- as incorrect. I also see people correcting this, with links like "[[FreedomBox/TargetedHardware|FreedomBox targetted hardware]]" -- overriding the link's location suggests the person writing it considered -t- an error.

As a dirty foreigner, I'd call the US speling inconsistent: you have:
* rut -> rutting
* cut -> cutting
* get -> getting (a three letter match!)
so seeing "-geting" makes me understand why Australians keep this spelling.
(0024662)
evilmike (developer)
2013-12-10 15:26

English doesn't have any official standard, nor do any english speaking countries. It's hard to identify what correct spelling is in some cases, since it's ultimately a matter of convention. That said, certain dictionaries have a lot of prestige and are generally used standards. The Oxford english dictionary is the best one. It's UK based obviously, but they document variant spellings. There's some sort of "international" standard that they use for preferred spellings, which isn't exactly UK english (though it's very close to Canadian for some bizarre reason). I guess it's a mix of british and american.

Here is their website's entry for "target" http://www.oxforddictionaries.com/definition/english/target?q=target [^]

I find this to be a much better standard than "australian english", which is more vaguely defined.
(0024663)
MarvinPA (developer)
2013-12-10 16:30

http://www.decd.sa.gov.au/northernadelaide/files/links/Spelling_resource_FINAL.pdf [^]

http://news.anu.edu.au/how-to/storytelling-writing-and-media/writing-style-guide/#T [^]

The "rule" is that consonants are doubled when the stress falls on the last syllable, which it does not here. Fixed, renaming the "mlist_targeting" option but adding a check so that the old spelling will also still work.

- Issue History
Date Modified Username Field Change
2013-12-09 08:33 putridmelon New Issue
2013-12-09 11:17 MarvinPA Relationship added duplicate of 0005268
2013-12-09 11:19 MarvinPA Note Added: 0024648
2013-12-09 11:20 MarvinPA Note Edited: 0024648
2013-12-09 11:20 MarvinPA Note Edited: 0024648
2013-12-09 12:15 putridmelon Note Added: 0024649
2013-12-09 12:20 putridmelon File Added: patch.txt
2013-12-09 12:21 putridmelon Note Added: 0024650
2013-12-10 09:18 galehar Note Added: 0024657
2013-12-10 14:21 KiloByte Note Added: 0024660
2013-12-10 15:26 evilmike Note Added: 0024662
2013-12-10 16:30 MarvinPA Note Added: 0024663
2013-12-10 16:48 MarvinPA Status new => resolved
2013-12-10 16:48 MarvinPA Fixed in Branch => 0.14 development branch
2013-12-10 16:48 MarvinPA Resolution open => done
2013-12-10 16:48 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker