Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007833 [DCSS] Bug Report minor always 2013-12-09 06:31 2018-04-23 04:08
Reporter putridmelon View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007833: restart_after_game is not on by default
Description Hit Escape during character creation (species selection screen, background screen, what's-your-name screen) and the app exits immediately without warning or explanation.

One would expect ESC to return to the previous page or cancel one's latest selection, some behavior consistent with the usage of ESC during the game, or at least ask for confirmation before exiting.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0007834closedneil App exits after tutorial-completion screen 

-  Notes
(0024680)
neil (administrator)
2013-12-11 07:36

You can set the option restart_after_game = true in your RC file to change this behaviour (also 0007834). Then pressing Esc during character creation (or exiting the game in general) returns you to the main menu.

Probably it makes sense to make this option the default for non-online games, as it's closer to what people expect for games with main menus. The option had several serious bugs for a long time, but these days it's much better.
(0024681)
neil (administrator)
2013-12-11 07:37

Retitled
(0031433)
Fixer (reporter)
2017-01-21 23:48

In 0.20a offline tiles I still have this problem, "use Escape to go back" is clearly misleading in character creation.
(0031434)
neil (administrator)
2017-01-21 23:51
edited on: 2017-01-22 01:05

Hm, at least in 0.20 trunk, and probably earlier, restart_after_game doesn't actually work if you hit Esc at the character name screen, because the relevant code calls end(0)

Edit: This specific problem is now fixed in 0.20-a0-510-g3b403f5.

(0032186)
advil (administrator)
2018-04-23 04:08

Just noticed this mantis issue; I cleaned up a bunch of this stuff in several commits over the course of 0.20-0.22 and eliminated all the remaining spurious uses of end/die I could as of 34c0b7be20fd2. restart_after_game is on by default since 34efee411a0d and together with the later change makes esc in menus generally a lot more sane.

- Issue History
Date Modified Username Field Change
2013-12-09 06:31 putridmelon New Issue
2013-12-11 07:36 neil Note Added: 0024680
2013-12-11 07:37 neil Note Added: 0024681
2013-12-11 07:37 neil Summary App exits immediately on ESC during character creation => restart_after_game is not on by default
2013-12-11 07:38 neil Relationship added has duplicate 0007834
2017-01-21 23:48 Fixer Note Added: 0031433
2017-01-21 23:51 neil Note Added: 0031434
2017-01-21 23:58 neil Note Edited: 0031434
2017-01-22 01:05 neil Note Edited: 0031434
2017-01-22 13:37 Fixer Issue Monitored: Fixer
2018-04-23 04:08 advil Note Added: 0032186
2018-04-23 04:08 advil Status new => resolved
2018-04-23 04:08 advil Fixed in Branch => 0.22 development branch
2018-04-23 04:08 advil Resolution open => done
2018-04-23 04:08 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker