Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007816 [DCSS] Bug Report minor always 2013-12-06 18:31 2013-12-11 21:19
Reporter tellian View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007816: *f and ctrl-f results immediately vanish from screen
Description When I do a find via either *f or ctrl-f, the results flash onto the screen then immediately vanish. I see the results long enough to see that they are populated with correct-looking information.

OS: Ubuntu 11.10 Desktop
Browser: Firefox 20.0

Version: 0.14-a0-1337-g1537c4c on CAO, I have also reproduced this on CSO git version as well. This does -not- happen when I play 0.13.

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024616)
Medar (developer)
2013-12-06 21:56

I can't seem to reproduce this.

Could potentially be an issue with old Firefox version.

You could see if any JavaScript errors are present by opening the web console (ctrl-shift-k).
(0024617)
tellian (reporter)
2013-12-06 22:20

Opened web console and repeated ctrl-f search. No javascript errors reported.
(0024687)
Medar (developer)
2013-12-11 10:07
edited on: 2013-12-11 10:07

This appears to be due to a bug in Firefox versions before 25:
https://bugzilla.mozilla.org/show_bug.cgi?id=501496 [^]
https://developer.mozilla.org/en-US/docs/Web/Reference/Events/keydown#preventDefault%28%29_of_keydown_event [^]

(0024688)
Medar (developer)
2013-12-11 10:25

Added a workaround in 0.14-a0-1415-ge301bcb.
(0024699)
tellian (reporter)
2013-12-11 21:19

I can confirm it does work now. Thanks.

- Issue History
Date Modified Username Field Change
2013-12-06 18:31 tellian New Issue
2013-12-06 21:56 Medar Note Added: 0024616
2013-12-06 22:20 tellian Note Added: 0024617
2013-12-11 10:07 Medar Note Added: 0024687
2013-12-11 10:07 Medar Note Edited: 0024687
2013-12-11 10:25 Medar Note Added: 0024688
2013-12-11 10:25 Medar Status new => resolved
2013-12-11 10:25 Medar Fixed in Branch => 0.14 development branch
2013-12-11 10:25 Medar Resolution open => done
2013-12-11 10:25 Medar Assigned To => Medar
2013-12-11 21:19 tellian Note Added: 0024699


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker