Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007784 [DCSS] Upload: Maps and Vaults minor N/A 2013-11-25 08:10 2014-01-01 03:34
Reporter badplayer View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007784: Add a sewer vault with scattered dead rats that can be reanimated by wandering kobolds
Description I understand vault monsters are typically frowned upon, but there are rare exceptions in vaults like the elementalist vault, and the sewer with the maliarial mermaid.

I wanted to use the Kobold here, because the creature is intrinsically thematic to the idea of a sewer vault. Watered-down necromancers or Shadow Imps don't fit the sewer theme at all, so I stuck with the Kobold.

What is unique here, is that the player has a challenge of dealing with the Kobold Necromancers while attempting to minimize their ability to animate nearby corpses. Retreating or moving will inevitably lead the reanimator to more fodder.

I have playtested this vault several times, and it's very fun.

Thanks for any feedback!
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Add-a-Kobold-Necromancer-sewer-vault.patch [^] (4,091 bytes) 2013-11-25 08:10 [Show Content]

- Relationships

-  Notes
(0024491)
KiloByte (manager)
2013-11-25 13:50

As for the use of custom vault monsters, this is exactly the usage this feature was made for. So this is ok.

Monster names don't use title case, though -- so s/Kobold_Necromancer/kobold_necromancer/.

It needs a n_des to give it the correct article.
(0024492)
Claws (developer)
2013-11-25 14:55

There's nothing about this vault* that makes it make more sense as a sewer than as a ossuary using a shadow imp, and it weakens the effect of either earlygame portal to directly overlap as such. Just dodge the controversy and put a gimmick where it is directly thematically linked** without needing multiple one-time unique special cases.

*besides easily removed water

**Yes, mummies are inextricably linked to demons, whatever.
(0024493)
KiloByte (manager)
2013-11-25 15:41

A necromancer doing his things hidden in a sewer makes sense. Random imps messing with mummies... not at all.

And most of the damage of 72ca79f hasn't been repaired yet.
(0024494)
Claws (developer)
2013-11-25 16:03

Mummy priests and greater mummies summon demons. The death curse effects from all non-basic mummies can summon several types of necromancy-linked demons, and two of the ossuaries have guardian mummies that can thus summon said demons upon death. I'm suggesting _one_ type of demon use, and it's a demon defined by the use of two necromancy spells, in a rare position to provide earlygame variety and have a 5 be a(n indirect) threat for once.
(0024496)
KiloByte (manager)
2013-11-25 16:44

Inserting a demon there -> weirdness.
Inserting a kobold necromancer there -> no weirdness, the only complaint is of a technical nature.
(0024501)
badplayer (reporter)
2013-11-26 08:11

Kilobytes line of thought is congruent with mine. I didn't want to do this as an ossuary. The idea of pagan Kobolds tucked away in a sewer experimenting on wild rats is compelling to me.

Necromancers in an ossuary presents a tantamount challenge, but just wasn't as interesting conceptually for me.
(0024521)
dpeg (administrator)
2013-11-28 14:22

I think the map is fine. I don't think any of the early portal vaults' theme is weakened from this. What I would suggest, though (apart from kilobyte's comments, which of course apply) is to make this rare. In general, Sewer maps don't have flat chances on purpose; this map would make a really good rare map, in my opinion (rare because the flavour indicates this is not your ordinary sewer).
(0024533)
neil (administrator)
2013-11-29 23:06
edited on: 2013-11-30 01:14

As for the name, I think I'd prefer "big kobold necromancer" so just name:necromancer n_suf would suffice.

Another problem is all those never_decay corpses. That's fine for skeletons, but you don't want to encourage players to collect and carry around the corpses as an emergency snack. Even with rotting corpses that's a problem: consider ghouls.

Unfortunately, delayed_decay doesn't work with alternatives, so you would need to use multiple glyphs and subst them randomly.

(Edit: I thought it didn't work with "rotting", but I was mistaken)

(0024538)
KiloByte (manager)
2013-11-30 01:15

+1 to preserving "big". It's unobvious that a necromancer would fight in melee harder than a regular kobold.
(0024896)
neil (administrator)
2014-01-01 03:34

In trunk (0.14-a0-1716-g6494201), thanks! I renamed the necromancer to "big kobold necromancer" and gave it WEIGHT: 3 per dpeg's suggestion.

I ended up fixing delayed_decay to work with alternatives. 0.14-a0-1718-g881850a makes this vault used delayed_decay instead of pure never_decay.

- Issue History
Date Modified Username Field Change
2013-11-25 08:10 badplayer New Issue
2013-11-25 08:10 badplayer File Added: 0001-Add-a-Kobold-Necromancer-sewer-vault.patch
2013-11-25 13:50 KiloByte Note Added: 0024491
2013-11-25 14:55 Claws Note Added: 0024492
2013-11-25 15:41 KiloByte Note Added: 0024493
2013-11-25 16:03 Claws Note Added: 0024494
2013-11-25 16:44 KiloByte Note Added: 0024496
2013-11-26 08:11 badplayer Note Added: 0024501
2013-11-28 14:22 dpeg Note Added: 0024521
2013-11-29 23:06 neil Note Added: 0024533
2013-11-30 01:14 neil Note Edited: 0024533
2013-11-30 01:15 KiloByte Note Added: 0024538
2014-01-01 03:34 neil Note Added: 0024896
2014-01-01 03:34 neil Status new => resolved
2014-01-01 03:34 neil Fixed in Branch => 0.14 development branch
2014-01-01 03:34 neil Resolution open => done
2014-01-01 03:34 neil Assigned To => neil
2014-01-01 10:13 badplayer Issue Monitored: badplayer


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker