Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007773 [DCSS] Patches minor N/A 2013-11-22 05:45 2013-11-22 16:15
Reporter blackcustard View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0007773: Fix yet another unlinked items bug; and six more small tweaks.
Description See the commit messages for details.

I was messing around a bit with a more substantial patch and I kept running into small things that were broken, so I fixed them.

I stuffed them all in one file since there are seven commits. Let me know if you want something different.
Additional Information
Tags No tags attached.
Attached Files ? file icon Fix_an_unlinked_items_bug_and_others.patch [^] (34,768 bytes) 2013-11-22 05:45 [Show Content]

- Relationships

-  Notes
(0024450)
neil (administrator)
2013-11-22 06:28

Applied in trunk (up to 0.14-a0-1007-gacdcbbe), and four of the commits in stable as well (up to 0.13.0-63-gbb6e277). Thanks!

Your patch was in UTF-16 encoding, which requires conversion to use with Unix toos. UTF-8 would be preferable.

Also, I fixed up a few problems with the find_connected_identical refactor: a few calls hadn't been updated, and the helper function should have been static.
(0024453)
blackcustard (reporter)
2013-11-22 07:31

Thank you for cleaning the patches up.

The encoding issue seems to be an artefact of the way I made the patch. I let Powershell touch the data while piping it to a file and it got re-encoded. I can fix that in the future. (Also it's only a problem when I try to combine patches into one file.)

- Issue History
Date Modified Username Field Change
2013-11-22 05:45 blackcustard New Issue
2013-11-22 05:45 blackcustard File Added: Fix_an_unlinked_items_bug_and_others.patch
2013-11-22 06:00 neil Status new => assigned
2013-11-22 06:00 neil Assigned To => neil
2013-11-22 06:28 neil Note Added: 0024450
2013-11-22 06:28 neil Status assigned => resolved
2013-11-22 06:28 neil Fixed in Branch => 0.14 development branch
2013-11-22 06:28 neil Resolution open => done
2013-11-22 07:31 blackcustard Note Added: 0024453
2013-11-22 16:15 blackcustard Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker